# CVE-2026-82660: Nodemailer jsonTransport bypasses disableFileAccess and disableUrlAccess

> Attackers can bypass file and URL access restrictions in Nodemailer's jsonTransport to read local files or fetch remote URLs.

- **Severity:** Medium 5.3 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:L/VI:L/VA:N/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 31 Aug 2026
- **Updated:** 31 Aug 2026
- **Also known as:** DEBIAN-CVE-2026-82660, ECHO-8b83-0589-b27b, GHSA-28mw-fm9r-fxjg, GHSA-wqvq-jvpq-h66f, MINI-48wg-wvxf-2v2x, MINI-6jgw-p42x-jf9g, MINI-6pqq-f9wc-x7h8, MINI-77fc-6w2r-rh4c, MINI-7hrq-4rw9-w863, MINI-7pgh-jprr-c3p4, MINI-cr5x-9m6r-7gg8, MINI-f428-8w2j-jcgg, MINI-f73x-6344-wh2q, MINI-fmwx-jmhv-r4gg, MINI-hhvq-w835-v864, MINI-j4gq-r2v7-ffjj, MINI-vq3j-7v2x-xcpx, MINI-w2qr-pfwv-q7h7, MINI-wr4w-f62g-6rh7, MINI-xv9p-353x-wr93, ROOT-APP-NPM-GHSA-wqvq-jvpq-h66f, UBUNTU-CVE-2026-82660

## What is CVE-2026-82660?

CVE-2026-82660 is a medium-severity vulnerability in nodemailer, published on 31 Aug 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Nodemailer before 8.0.9 fails to enforce disableFileAccess and disableUrlAccess options during message normalization in jsonTransport. Attackers can read local files or fetch URLs by supplying path or href values in message content fields, bypassing intended access controls.

Weakness: CWE-862 (Missing Authorization)

## Which versions are affected by CVE-2026-82660?

2 open source packages ship an affected version, including nodemailer.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `nodemailer` | npm | All versions | 8.0.9 |
| `nodemailer` | npm | All versions | 8.0.9 |

## How do I fix CVE-2026-82660?

Upgrade nodemailer to 8.0.9 or later.

## Is CVE-2026-82660 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-82660 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-82660 and fix it if it is affected.

What it is: CVE-2026-82660 is a medium-severity vulnerability in nodemailer, published on 31 Aug 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-82660 exists.

Affected packages and fixed versions:
- nodemailer (npm): affected all versions; fixed in 8.0.9
- nodemailer (npm): affected all versions; fixed in 8.0.9

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-82660/ (Markdown: https://insights.sbomify.com/CVE-2026-82660/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-82660
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-82660
- OSV: https://osv.dev/vulnerability/CVE-2026-82660

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-82660/
Summaries are generated and may contain mistakes; the official description above is the record.
