# CVE-2026-82661: Nodemailer CRLF Injection via List-* Header Comments

> Attackers can inject CRLF sequences into email headers via list comments, altering message semantics and client behavior in Nodemailer.

- **Severity:** Medium 5.3 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:L/VI:L/VA:N/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 31 Aug 2026
- **Updated:** 2 Sep 2026
- **Also known as:** CLSA-2026-1784596338, DEBIAN-CVE-2026-82661, ECHO-72a1-437a-b6a9, GHSA-268h-hp4c-crq3, GHSA-2jv2-wqrj-g6x7, MINI-2w55-h3h4-vr8p, MINI-3q83-p43r-5j4w, MINI-4pww-hhhr-j2rp, MINI-6v84-9ccg-hrgp, MINI-99c3-7w22-v89q, MINI-9w2p-8wgw-5373, MINI-9wr3-r34m-32mj, MINI-cw5c-2c8c-6mqx, MINI-hhqg-2f6w-h749, MINI-hwgr-v226-ww3j, MINI-m5h9-gm64-hgvc, MINI-m627-x28x-2pqg, MINI-mxwj-qv4j-fpmc, MINI-v2f9-rpvr-fp58, MINI-vmgh-5r8m-xqgp, MINI-x856-pwmf-92c8, ROOT-APP-NPM-GHSA-268h-hp4c-crq3, UBUNTU-CVE-2026-82661

## What is CVE-2026-82661?

CVE-2026-82661 is a medium-severity vulnerability in nodemailer, published on 31 Aug 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Nodemailer before 8.0.9 fails to sanitize carriage return and line feed characters in list comment fields, allowing attackers to inject arbitrary message headers. An attacker with control over list.*.comment parameters can inject CRLF sequences to create additional headers in generated RFC822 messages, altering mail client behavior and message semantics.

Weakness: CWE-93 (Improper Neutralization of CRLF Sequences)

## Which versions are affected by CVE-2026-82661?

2 open source packages ship an affected version, including nodemailer.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `nodemailer` | npm | All versions | 8.0.9 |
| `nodemailer` | npm | All versions | 8.0.9 |

## How do I fix CVE-2026-82661?

Upgrade nodemailer to 8.0.9 or later.

## Is CVE-2026-82661 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-82661 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-82661 and fix it if it is affected.

What it is: CVE-2026-82661 is a medium-severity vulnerability in nodemailer, published on 31 Aug 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-82661 exists.

Affected packages and fixed versions:
- nodemailer (npm): affected all versions; fixed in 8.0.9
- nodemailer (npm): affected all versions; fixed in 8.0.9

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-82661/ (Markdown: https://insights.sbomify.com/CVE-2026-82661/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-82661
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-82661
- OSV: https://osv.dev/vulnerability/CVE-2026-82661

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-82661/
Summaries are generated and may contain mistakes; the official description above is the record.
