# CVE-2026-82666: yaojingang GEOFlow Superadmin Theme Editor SiteThemeEditorController.php preview code injection

> Remote attackers with admin privileges can inject code via the theme editor preview function, leading to arbitrary code execution.

- **Severity:** Medium 5.1 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:H/UI:N/VC:L/VI:L/VA:L/SC:N/SI:N/SA:N/E:P`)
- **Exploited in the wild:** Not known
- **Login needed:** An administrator
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** No
- **Published:** 31 Aug 2026
- **Updated:** 31 Aug 2026
- **Also known as:** GHSA-254c-3p3v-hv7x

## What is CVE-2026-82666?

CVE-2026-82666 is a medium-severity code injection vulnerability in yaojingang GEOFlow, published on 31 Aug 2026. An attacker needs administrator access to exploit it, with no action from the victim.

### Official description

A flaw has been found in yaojingang GEOFlow up to 2.1.0. This issue affects the function preview of the file app/Http/Controllers/Admin/SiteThemeEditorController.php of the component Superadmin Theme Editor. This manipulation of the argument blade causes code injection. It is possible to initiate the attack remotely. The exploit has been published and may be used. Upgrading to version 2.1.1 is capable of addressing this issue. Patch name: 67abfd864a15d169a78429f3290c91cb3b93e849. Upgrading the affected component is advised.

Weakness: CWE-94 (Improper Control of Generation of Code), CWE-74 (Improper Neutralization of Special Elements in Output Used by a Downstream Component)

## Which versions are affected by CVE-2026-82666?


## How do I fix CVE-2026-82666?

No fix has been published for CVE-2026-82666 yet. Limit exposure of the affected software until one is available.

## Is CVE-2026-82666 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-82666 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-82666 and fix it if it is affected.

What it is: CVE-2026-82666 is a medium-severity code injection vulnerability in yaojingang GEOFlow, published on 31 Aug 2026. An attacker needs administrator access to exploit it, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-82666 exists.

Affected product: yaojingang GEOFlow. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-82666/ (Markdown: https://insights.sbomify.com/CVE-2026-82666/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-82666
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-82666
- OSV: https://osv.dev/vulnerability/CVE-2026-82666

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-82666/
Summaries are generated and may contain mistakes; the official description above is the record.
