# CVE-2026-82736: Ash.Type.CiString validates length and match constraints before case folding, allowing constraint bypass

> Attackers can bypass length and match constraints on case-insensitive strings by exploiting validation order, leading to invalid data storage.

- **Severity:** Low 2.1 (`CVSS:4.0/AV:L/AC:L/AT:P/PR:N/UI:N/VC:N/VI:L/VA:N/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Local or same network only
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 1 Sep 2026
- **Updated:** 1 Sep 2026
- **Also known as:** EEF-CVE-2026-82736, GHSA-gg9w-7593-hxg9

## What is CVE-2026-82736?

CVE-2026-82736 is a low-severity vulnerability in ash-project ash, published on 1 Sep 2026. It can only be exploited from the same machine or local network, with no action from the victim.

### Official description

Incorrect Behavior Order: Validate Before Canonicalize vulnerability in ash-project ash lets an attacker store a case-insensitive string value that violates its length or match constraints.

Ash.Type.CiString.apply_constraints/2 (lib/ash/type/ci_string.ex) validated the max_length, min_length, and match constraints against the value as submitted, while the type case-folds the string (per its casing) for storage and comparison. Because validation ran before folding, an attacker can submit a value whose folded form breaks a constraint but whose original form passes: for example, against a match pattern requiring uppercase, an uppercase value that is stored lowercased persists a value the pattern rejects. The fix case-folds the value at the start of apply_constraints/2, so the constraints are checked against the form that is actually stored.

This issue affects ash: from 1.29.0-rc0 before 3.32.2.

Weakness: CWE-180 (Incorrect Behavior Order: Validate Before Canonicalize)

## Which versions are affected by CVE-2026-82736?

1 open source package ship an affected version, including ash.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `ash` | Hex | From 1.29.0-rc0 | 3.32.2 |

## How do I fix CVE-2026-82736?

Upgrade ash to 3.32.2 or later.

## Is CVE-2026-82736 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-82736 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-82736 and fix it if it is affected.

What it is: CVE-2026-82736 is a low-severity vulnerability in ash-project ash, published on 1 Sep 2026. It can only be exploited from the same machine or local network, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-82736 exists.

Affected packages and fixed versions:
- ash (Hex): affected from 1.29.0-rc0; fixed in 3.32.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-82736/ (Markdown: https://insights.sbomify.com/CVE-2026-82736/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-82736
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-82736
- OSV: https://osv.dev/vulnerability/CVE-2026-82736

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-82736/
Summaries are generated and may contain mistakes; the official description above is the record.
