# CVE-2026-82737: Ash.Vector wraps the 16-bit dimension header for vectors over 65,535 elements, corrupting data and crashing reads

> An attacker can cause denial of service and data corruption by submitting vectors with more than 65,535 elements, triggering an integer overflow in the Ash library.

- **Severity:** Medium 5.9 (`CVSS:4.0/AV:L/AC:L/AT:P/PR:N/UI:N/VC:N/VI:L/VA:H/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Local or same network only
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 1 Sep 2026
- **Updated:** 1 Sep 2026
- **Also known as:** EEF-CVE-2026-82737, GHSA-68q3-w4w3-2gfv

## What is CVE-2026-82737?

CVE-2026-82737 is a medium-severity vulnerability in ash-project ash, published on 1 Sep 2026. It can only be exploited from the same machine or local network, with no action from the victim.

### Official description

Integer Overflow or Wraparound vulnerability in ash-project ash lets an attacker corrupt a stored vector and crash later reads of it by submitting a vector with more than 65,535 elements.

Ash.Vector.new/1 (lib/ash/vector.ex) encodes a vector as <<dim::unsigned-16, 0::unsigned-16>> followed by the element floats, packing the element count into a 16-bit field without checking its range. A list of more than 65,535 elements wraps the dimension modulo 65,536, so the encoded header records a dimension that disagrees with the number of stored floats. from_binary/1 later reads binary-size(dim)-unit(32) from the wrapped header, so every read of the corrupted value misparses and raises, denying access to the affected record. The fix rejects any vector whose dimension exceeds 65,535.

This issue affects ash: from 2.14.13 before 3.32.2.

Weakness: CWE-190 (Integer Overflow or Wraparound)

## Which versions are affected by CVE-2026-82737?

1 open source package ship an affected version, including ash.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `ash` | Hex | From 2.14.13 | 3.32.2 |

## How do I fix CVE-2026-82737?

Upgrade ash to 3.32.2 or later.

## Is CVE-2026-82737 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-82737 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-82737 and fix it if it is affected.

What it is: CVE-2026-82737 is a medium-severity vulnerability in ash-project ash, published on 1 Sep 2026. It can only be exploited from the same machine or local network, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-82737 exists.

Affected packages and fixed versions:
- ash (Hex): affected from 2.14.13; fixed in 3.32.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-82737/ (Markdown: https://insights.sbomify.com/CVE-2026-82737/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-82737
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-82737
- OSV: https://osv.dev/vulnerability/CVE-2026-82737

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-82737/
Summaries are generated and may contain mistakes; the official description above is the record.
