# CVE-2026-82738: Ash.Type.UUIDv7 accepts non-v7 UUIDs that then fail to load, causing persistent denial of service

> Attackers can permanently deny access to records by storing invalid UUIDs, causing persistent read failures in the Ash framework.

- **Severity:** Medium 5.9 (`CVSS:4.0/AV:L/AC:L/AT:P/PR:N/UI:N/VC:N/VI:N/VA:H/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Local or same network only
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 1 Sep 2026
- **Updated:** 1 Sep 2026
- **Also known as:** EEF-CVE-2026-82738, GHSA-7xfw-9jwm-9c4c

## What is CVE-2026-82738?

CVE-2026-82738 is a medium-severity denial of service vulnerability in ash-project ash, published on 1 Sep 2026. It can only be exploited from the same machine or local network, with no action from the victim.

### Official description

Improper Input Validation vulnerability in ash-project ash allows an attacker to persistently deny reads of a record by storing a non-version-7 UUID in an Ash.Type.UUIDv7 attribute.

Ash.Type.UUIDv7.cast_input/2 accepts any well-formed UUID string, including non-version-7 UUIDs, and stores it as a 16-byte binary. On read, cast_stored/2 (lib/ash/type/uuid_v7.ex) routes the stored binary back through cast_input/2, which since an input-validation tightening in v3.6.3 matches only version-7 (and optionally version-4) 16-byte binaries and otherwise expects a 36-character string. A stored non-v7 16-byte binary matches neither clause and returns :error, so every later read of that record fails. An attacker able to set such an attribute poisons the row permanently. The fix decodes any 16-byte stored binary directly in cast_stored/2.

This issue affects ash: from 3.6.3 before 3.32.2.

Weakness: CWE-20 (Improper Input Validation)

## Which versions are affected by CVE-2026-82738?

1 open source package ship an affected version, including ash.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `ash` | Hex | From 3.6.3 | 3.32.2 |

## How do I fix CVE-2026-82738?

Upgrade ash to 3.32.2 or later.

## Is CVE-2026-82738 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-82738 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-82738 and fix it if it is affected.

What it is: CVE-2026-82738 is a medium-severity denial of service vulnerability in ash-project ash, published on 1 Sep 2026. It can only be exploited from the same machine or local network, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-82738 exists.

Affected packages and fixed versions:
- ash (Hex): affected from 3.6.3; fixed in 3.32.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-82738/ (Markdown: https://insights.sbomify.com/CVE-2026-82738/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-82738
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-82738
- OSV: https://osv.dev/vulnerability/CVE-2026-82738

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-82738/
Summaries are generated and may contain mistakes; the official description above is the record.
