{"answers":{"affected":"1 open source package ship an affected version, including ash.","exploited":"It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-82740 exists.","fix":"Upgrade ash to 3.32.2 or later.","what":"CVE-2026-82740 is a low-severity vulnerability in ash-project ash, published on 1 Sep 2026. It can only be exploited from the same machine or local network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2026-82740 and fix it if it is affected.\n\nWhat it is: CVE-2026-82740 is a low-severity vulnerability in ash-project ash, published on 1 Sep 2026. It can only be exploited from the same machine or local network, with no action from the victim.\nExploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-82740 exists.\n\nAffected packages and fixed versions:\n- ash (Hex): affected from 2.16.1; fixed in 3.32.2\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2026-82740/ (Markdown: https://insights.sbomify.com/CVE-2026-82740/index.md)","id":"CVE-2026-82740","markdown":"https://insights.sbomify.com/CVE-2026-82740/index.md","name":"CVE-2026-82740","record":{"aliases":["EEF-CVE-2026-82740","GHSA-v29m-p28g-w5fc"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["data_modify"],"network_reachable":"adjacent_or_local","non_default_config":false,"product_category":"Elixir Ash framework","requires_auth":"none","summary":"Attackers can bypass validation to persist invalid nested array data in Ash applications, requiring an upgrade to the Ash library.","user_interaction":"not_required","vuln_class":"other"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"EEF","cpe":[],"cvss":{"score":2.1,"severity":"low","source":"cna","vector":"CVSS:4.0/AV:L/AC:L/AT:P/PR:N/UI:N/VC:N/VI:L/VA:N/SC:N/SI:N/SA:N","version":"4.0"},"cwes":[{"id":"CWE-20","name":"Improper Input Validation"}],"description":"Improper Input Validation vulnerability in ash-project ash fails to enforce the outer array constraints on a doubly-nested {:array, {:array, type}} attribute, letting invalid input pass validation.\n\nAsh.Type.apply_constraints/3 (lib/ash/type/type.ex) handled the {:array, {:array, type}} case by mapping only the inner {:array, type} constraints over each element, so constraints declared on the outer array (such as min_length, max_length, and nil_items?) were never applied. An attacker could submit an outer list that violates those constraints (too many elements, or nil entries where disallowed) and have it accepted and persisted. The fix enforces the outer array constraints and adds explicit handling for nil and non-list inputs.\n\nThis issue affects ash: from 2.16.1 before 3.32.2.","ecosystems":["Hex"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"weaponised"},"has_fix":true,"headline":"Ash.Type ignores outer array constraints on nested {:array, {:array, type}} inputs","id":"CVE-2026-82740","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Hex","product":null,"products":[],"type":"other","year":"2026"},"n_packages":1,"n_references":4,"next":{"headline":"Ash.Type.Union with :map_with_tag does not force the tag on dump, enabling tag confusion","id":"CVE-2026-82741"},"packages":[{"ecosystem":"Hex","fixed":["3.32.2"],"introduced":["2.16.1"],"last_affected":[],"package":"ash","purl":"pkg:hex/ash","source":"EEF-CVE-2026-82740"}],"prev":{"headline":"Ash.Resource.Validation.Confirm leaks a confirmed field's stored value in the atomic mismatch error","id":"CVE-2026-82739"},"products":["ash"],"published":"2026-09-01","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"Erlang Ecosystem Foundation","prefix":"EEF"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"poc","technical_impact":"partial"},"state":"PUBLISHED","updated":"2026-09-01","vendors":["ash-project"]},"summary":"Attackers can bypass validation to persist invalid nested array data in Ash applications, requiring an upgrade to the Ash library.","url":"https://insights.sbomify.com/CVE-2026-82740/"}