# CVE-2026-82745: ETS and Mnesia data layers overwrite an existing record on create instead of enforcing primary-key uniqueness

> Attackers can overwrite existing records by supplying a matching primary key during creation, bypassing update policies and destroying data.

- **Severity:** Medium 5.9 (`CVSS:4.0/AV:L/AC:L/AT:P/PR:N/UI:N/VC:N/VI:H/VA:N/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Local or same network only
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 1 Sep 2026
- **Updated:** 1 Sep 2026
- **Also known as:** EEF-CVE-2026-82745, GHSA-92x7-q3h5-wf88

## What is CVE-2026-82745?

CVE-2026-82745 is a medium-severity vulnerability in ash-project ash, published on 1 Sep 2026. It can only be exploited from the same machine or local network, with no action from the victim.

### Official description

Improper Access Control vulnerability in ash-project ash lets a create action overwrite an existing record when the ETS or Mnesia data layer is used, because neither enforced primary-key uniqueness on insert.

Unlike a SQL data layer, whose unique primary-key constraint rejects a duplicate, the ETS and Mnesia data layers implemented create as a keyed insert that replaces any existing entry with the same primary key (lib/ash/data_layer/ets/ets.ex, lib/ash/data_layer/mnesia/mnesia.ex). An actor who can set the primary key on a create (for example a user-supplied string or integer key) can submit a create whose key matches an existing record and silently overwrite it, destroying and replacing another entity's data without going through the update action or its policies. The fix rejects a create whose primary key already exists with an already-taken error, and only allows duplicates for keyless resources.

This issue affects ash: from 0.4.0 before 3.32.2.

Weakness: CWE-284 (Improper Access Control)

## Which versions are affected by CVE-2026-82745?

1 open source package ship an affected version, including ash.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `ash` | Hex | From 0.4.0 | 3.32.2 |

## How do I fix CVE-2026-82745?

Upgrade ash to 3.32.2 or later.

## Is CVE-2026-82745 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-82745 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-82745 and fix it if it is affected.

What it is: CVE-2026-82745 is a medium-severity vulnerability in ash-project ash, published on 1 Sep 2026. It can only be exploited from the same machine or local network, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-82745 exists.

Affected packages and fixed versions:
- ash (Hex): affected from 0.4.0; fixed in 3.32.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-82745/ (Markdown: https://insights.sbomify.com/CVE-2026-82745/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-82745
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-82745
- OSV: https://osv.dev/vulnerability/CVE-2026-82745

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-82745/
Summaries are generated and may contain mistakes; the official description above is the record.
