# CVE-2026-82747: Ash.Policy.Authorizer returns records denied by a runtime read policy to any actor

> Attackers can access records denied by runtime read policies due to a logic error in Ash.Policy.Authorizer, exposing sensitive data to unauthorized actors.

- **Severity:** Medium 5.9 (`CVSS:4.0/AV:L/AC:L/AT:P/PR:N/UI:N/VC:H/VI:N/VA:N/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Local or same network only
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 1 Sep 2026
- **Updated:** 1 Sep 2026
- **Also known as:** EEF-CVE-2026-82747, GHSA-4259-gvr2-4xhq

## What is CVE-2026-82747?

CVE-2026-82747 is a medium-severity missing authorization vulnerability in ash-project ash, published on 1 Sep 2026. It can only be exploited from the same machine or local network, with no action from the victim.

### Official description

Incorrect Authorization vulnerability in ash-project ash returns records that a runtime read policy denies to any actor.

When a resource has an access_type :runtime read policy (a check evaluated per record rather than compiled to a filter), Ash.Policy.Authorizer decides each record in check_result/1 (lib/ash/policy/authorizer/authorizer.ex) by discarding impossible policy scenarios and inspecting what remains. When every scenario for a record was impossible, meaning no policy can authorize it and it must be forbidden, the empty-scenario branch instead kept the record ({[record | data], authorizer, any_forbidden?}) and returned it as authorized. As a result, records the runtime read policy denies are returned to any actor. The fix forbids a record whose scenarios are all impossible.

This issue affects ash: from 3.4.44 before 3.32.2.

Weakness: CWE-863 (Incorrect Authorization)

## Which versions are affected by CVE-2026-82747?

1 open source package ship an affected version, including ash.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `ash` | Hex | From 3.4.44 | 3.32.2 |

## How do I fix CVE-2026-82747?

Upgrade ash to 3.32.2 or later.

## Is CVE-2026-82747 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-82747 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-82747 and fix it if it is affected.

What it is: CVE-2026-82747 is a medium-severity missing authorization vulnerability in ash-project ash, published on 1 Sep 2026. It can only be exploited from the same machine or local network, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-82747 exists.

Affected packages and fixed versions:
- ash (Hex): affected from 3.4.44; fixed in 3.32.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-82747/ (Markdown: https://insights.sbomify.com/CVE-2026-82747/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-82747
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-82747
- OSV: https://osv.dev/vulnerability/CVE-2026-82747

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-82747/
Summaries are generated and may contain mistakes; the official description above is the record.
