CVE-2026-8280 Allocation of Resources Without Limits or Throttling in GitLab

Medium 6.5 Published Updated

An authenticated user can cause denial of service in GitLab by triggering excessive memory consumption through improper input validation.

Exploited in the wild
Not known
Login needed
Any signed-in user
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2026-8280?

CVE-2026-8280 is a medium-severity denial of service vulnerability in Gitlab Gitlab, published on 14 May 2026. Any signed-in user can exploit it over the network, with no action from the victim.

Official description

GitLab has remediated an issue in GitLab CE/EE affecting all versions from 8.3 before 18.9.7, 18.10 before 18.10.6, and 18.11 before 18.11.3 that could have allowed an authenticated user to cause denial of service through excessive memory consumption due to improper input validation.

Weakness: CWE-770

Which versions are affected by CVE-2026-8280?

1 open source package ship an affected version, including gitlab. It affects 1 product.

PackageAffectedFixed in
gitlab BitnamiFrom 8.3.018.9.7, 18.10.6, 18.11.3

Products include Gitlab Gitlab.

How do I fix CVE-2026-8280?

Upgrade gitlab to a fixed version for your release line: 18.9.7, 18.10.6 or 18.11.3.

Upgrade, then put limits on request size, rate and nesting depth so one client cannot exhaust the service. More about Denial of service.

Is CVE-2026-8280 being exploited?

There is no known exploitation of CVE-2026-8280 in the wild and no public exploit code.

All Gitlab Gitlab vulnerabilities

Sources

Also known as BIT-gitlab-2026-8280, GHSA-fqvq-p2gc-c297, MINI-3vm5-259v-944f, MINI-49m6-9ww3-j28w, MINI-4fqh-pr5g-hr3q, MINI-4gmh-2x3q-3chc and 37 more.

Is CVE-2026-8280 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free