# CVE-2026-82804: Apache DolphinScheduler: Command Injection in the Alert Script Plugin

> An authenticated user can execute arbitrary commands via shell metacharacters in resource filenames used by the Alert Script plugin.

- **Severity:** High 8.8 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** No
- **Published:** 29 Sep 2026
- **Updated:** 29 Sep 2026
- **Also known as:** GHSA-6m78-8x87-73vx

## What is CVE-2026-82804?

CVE-2026-82804 is a high-severity command injection vulnerability in Apache DolphinScheduler, published on 29 Sep 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

The scriptPath parameter is incorporated into a /bin/sh -c command without sufficient neutralization of shell metacharacters, allowing shell command substitution and execution.

An authenticated user can exploit this behavior by creating a resource whose filename contains shell command substitution syntax, such as $(...), and subsequently supplying the resulting path to the Alert Script plugin's /test-send endpoint. When the alert script is executed, the shell interprets the injected command, resulting in arbitrary command execution with the privileges of the DolphinScheduler service process.

This issue affects Apache DolphinScheduler: before 3.4.3.

Users are recommended to upgrade to version 3.4.3, which fixes the issue.

Weakness: CWE-78 (Improper Neutralization of Special Elements used in an OS Command)

## Which versions are affected by CVE-2026-82804?


## How do I fix CVE-2026-82804?

No fix has been published for CVE-2026-82804 yet. Limit exposure of the affected software until one is available.

## Is CVE-2026-82804 being exploited?

There is no known exploitation of CVE-2026-82804 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-82804 and fix it if it is affected.

What it is: CVE-2026-82804 is a high-severity command injection vulnerability in Apache DolphinScheduler, published on 29 Sep 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-82804 in the wild and no public exploit code.

Affected product: Apache DolphinScheduler. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-82804/ (Markdown: https://insights.sbomify.com/CVE-2026-82804/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-82804
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-82804
- OSV: https://osv.dev/vulnerability/CVE-2026-82804

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-82804/
Summaries are generated and may contain mistakes; the official description above is the record.
