CVE-2026-82806 Apache APISIX: cross-request permission pollution via static permission list mutation

Medium 5.3 Published Updated

Attackers can gain unauthorized access to protected resources due to permission state leaking between requests in Apache APISIX with Keycloak auth.

Exploited in the wild
Not known
Login needed
Any signed-in user
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2026-82806?

CVE-2026-82806 is a medium-severity authentication bypass vulnerability in Apache APISIX, published on 1 Oct 2026. Any signed-in user can exploit it over the network, with no action from the victim.

Official description

Exposure of data element to wrong session vulnerability in Apache APISIX.

This issue affects Apache APISIX: from 2.3.0 before 3.7.0.

Under a supported authz-keycloak configuration, a request's authorization scope could persist into later requests on the same route, leading to unintended authorization expansion and inconsistent access-control decisions.

Users are recommended to upgrade to version 3.7.0 or higher, which fixes the issue.

Weakness: CWE-488

Which versions are affected by CVE-2026-82806?

1 open source package ship an affected version, including apisix.

PackageAffectedFixed in
apisix BitnamiFrom 2.3.03.7.0

How do I fix CVE-2026-82806?

Upgrade apisix to 3.7.0 or later.

Upgrade, and rotate credentials and sessions that may have been exposed. More about Authentication bypass.

Is CVE-2026-82806 being exploited?

There is no known exploitation of CVE-2026-82806 in the wild and no public exploit code.

Sources

Also known as BIT-apisix-2026-82806, GHSA-2252-4rmp-q4vj.

Is CVE-2026-82806 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free