{"answers":{"affected":"1 open source package ship an affected version, including apisix.","exploited":"There is no known exploitation of CVE-2026-82806 in the wild and no public exploit code.","fix":"Upgrade apisix to 3.7.0 or later.","what":"CVE-2026-82806 is a medium-severity authentication bypass vulnerability in Apache APISIX, published on 1 Oct 2026. Any signed-in user can exploit it over the network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2026-82806 and fix it if it is affected.\n\nWhat it is: CVE-2026-82806 is a medium-severity authentication bypass vulnerability in Apache APISIX, published on 1 Oct 2026. Any signed-in user can exploit it over the network, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2026-82806 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- apisix (Bitnami): affected from 2.3.0; fixed in 3.7.0\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2026-82806/ (Markdown: https://insights.sbomify.com/CVE-2026-82806/index.md)","id":"CVE-2026-82806","markdown":"https://insights.sbomify.com/CVE-2026-82806/index.md","name":"CVE-2026-82806","record":{"aliases":["BIT-apisix-2026-82806","GHSA-2252-4rmp-q4vj"],"analysis":{"component_type":"server_software","fix_type":"upgrade","impacts":["security_bypass","data_read"],"network_reachable":"yes","non_default_config":true,"product_category":"API Gateway","requires_auth":"low_privilege","summary":"Attackers can gain unauthorized access to protected resources due to permission state leaking between requests in Apache APISIX with Keycloak auth.","user_interaction":"not_required","vuln_class":"auth_bypass"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"apache","cpe":[],"cvss":{"score":5.3,"severity":"medium","source":"cna","vector":"CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:N/VI:N/VA:N/SC:L/SI:L/SA:N","version":"4.0"},"cwes":[{"id":"CWE-488","name":"Exposure of Data Element to Wrong Session"}],"description":"Exposure of data element to wrong session vulnerability in Apache APISIX.\n\nThis issue affects Apache APISIX: from 2.3.0 before 3.7.0.\n\nUnder a supported authz-keycloak configuration, a request's authorization scope could persist into later requests on the same route, leading to unintended authorization expansion and inconsistent access-control decisions.\n\nUsers are recommended to upgrade to version 3.7.0 or higher, which fixes the issue.","ecosystems":["Bitnami"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Apache APISIX: cross-request permission pollution via static permission list mutation","id":"CVE-2026-82806","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Bitnami","product":null,"products":[],"type":"auth_bypass","year":"2026"},"n_packages":1,"n_references":1,"next":{"headline":"ieungSoft Ultra RAMDisk Pro Kernel Driver URDSCSI.sys privileges management","id":"CVE-2026-82807"},"packages":[{"ecosystem":"Bitnami","fixed":["3.7.0"],"introduced":["2.3.0"],"last_affected":[],"package":"apisix","purl":"pkg:bitnami/apisix","source":"BIT-apisix-2026-82806"}],"prev":{"headline":"Typora Mermaid Rendering cross site scripting","id":"CVE-2026-82805"},"products":["Apache APISIX"],"published":"2026-10-01","related":[],"sources":[{"class":"attribution","licence":"Apache-2.0","name":"Bitnami","prefix":"BIT"},{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2026-10-01","vendors":["Apache Software Foundation"]},"summary":"Attackers can gain unauthorized access to protected resources due to permission state leaking between requests in Apache APISIX with Keycloak auth.","url":"https://insights.sbomify.com/CVE-2026-82806/"}