# CVE-2026-82806: Apache APISIX: cross-request permission pollution via static permission list mutation

> Attackers can gain unauthorized access to protected resources due to permission state leaking between requests in Apache APISIX with Keycloak auth.

- **Severity:** Medium 5.3 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:N/VI:N/VA:N/SC:L/SI:L/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 1 Oct 2026
- **Updated:** 1 Oct 2026
- **Also known as:** BIT-apisix-2026-82806, GHSA-2252-4rmp-q4vj

## What is CVE-2026-82806?

CVE-2026-82806 is a medium-severity authentication bypass vulnerability in Apache APISIX, published on 1 Oct 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Exposure of data element to wrong session vulnerability in Apache APISIX.

This issue affects Apache APISIX: from 2.3.0 before 3.7.0.

Under a supported authz-keycloak configuration, a request's authorization scope could persist into later requests on the same route, leading to unintended authorization expansion and inconsistent access-control decisions.

Users are recommended to upgrade to version 3.7.0 or higher, which fixes the issue.

Weakness: CWE-488 (Exposure of Data Element to Wrong Session)

## Which versions are affected by CVE-2026-82806?

1 open source package ship an affected version, including apisix.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `apisix` | Bitnami | From 2.3.0 | 3.7.0 |

## How do I fix CVE-2026-82806?

Upgrade apisix to 3.7.0 or later.

## Is CVE-2026-82806 being exploited?

There is no known exploitation of CVE-2026-82806 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-82806 and fix it if it is affected.

What it is: CVE-2026-82806 is a medium-severity authentication bypass vulnerability in Apache APISIX, published on 1 Oct 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-82806 in the wild and no public exploit code.

Affected packages and fixed versions:
- apisix (Bitnami): affected from 2.3.0; fixed in 3.7.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-82806/ (Markdown: https://insights.sbomify.com/CVE-2026-82806/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-82806
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-82806
- OSV: https://osv.dev/vulnerability/CVE-2026-82806

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-82806/
Summaries are generated and may contain mistakes; the official description above is the record.
