CVE-2026-82837 Insertion of Sensitive Information Into Sent Data in GitLab

Medium 5.3 Published Updated

Authenticated users can access sensitive credentials and tokens via internal endpoints due to improper authorization checks in GitLab.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2026-82837?

CVE-2026-82837 is a medium-severity vulnerability in Gitlab Gitlab, published on 15 Sep 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

Official description

GitLab has remediated an issue in GitLab CE/EE affecting all versions from 10.1.0 before 19.1.8, 19.2 before 19.2.6, and 19.3 before 19.3.2 that certain conditions could have allowed an authenticated user to access sensitive credentials and tokens without transiting the expected proxy due to improper authorization checks on internal data emission endpoints.

Weakness: CWE-522, CWE-201

Which versions are affected by CVE-2026-82837?

1 open source package ship an affected version, including gitlab. It affects 1 product.

PackageAffectedFixed in
gitlab BitnamiFrom 10.1.019.1.8, 19.2.6, 19.3.2

Products include Gitlab Gitlab.

How do I fix CVE-2026-82837?

Upgrade gitlab to a fixed version for your release line: 19.1.8, 19.2.6 or 19.3.2.

Is CVE-2026-82837 being exploited?

There is no known exploitation of CVE-2026-82837 in the wild and no public exploit code.

All Gitlab Gitlab vulnerabilities

Sources

Also known as BIT-gitlab-2026-82837, GHSA-2gcw-p589-35qf, MINI-598q-3v4w-783w, MINI-hgrh-pc5j-54cf, MINI-xw47-qcjx-gjmv.

Is CVE-2026-82837 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free