# CVE-2026-82853: Nodemailer before 8.0.5 SMTP Command Injection via CRLF

> Attackers can inject arbitrary SMTP commands via the transport name option, enabling email spoofing and phishing attacks.

- **Severity:** Medium 6.9 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:H/UI:N/VC:N/VI:H/VA:N/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** An administrator
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 31 Aug 2026
- **Updated:** 31 Aug 2026
- **Also known as:** CLEANSTART-2026-XN13622, DEBIAN-CVE-2026-82853, ECHO-2e01-a0c3-6c54, GHSA-q8rv-95x3-46j5, GHSA-vvjj-xcjg-gr5g, MINI-22wh-3chv-vj75, MINI-325r-qxxm-27w8, MINI-5568-hxhp-2h8j, MINI-6jgf-h5fv-6vp3, MINI-6xqv-p284-w7v2, MINI-8wh7-r2qj-q8pv, MINI-crwx-w6vw-vg7p, MINI-fmw8-977x-pm7h, MINI-fx9g-qpv3-4grh, MINI-g4r8-wvmq-6g9h, MINI-mg75-9mhv-c843, MINI-q7p4-r7cx-g883, MINI-r6cf-rjv5-r7px, MINI-vm7h-4hq9-pw2m, MINI-wq4q-92h7-3mjg, MINI-x4f9-rqrc-2wxg, MINI-x4rm-2j75-vw92, ROOT-APP-NPM-GHSA-vvjj-xcjg-gr5g, UBUNTU-CVE-2026-82853

## What is CVE-2026-82853?

CVE-2026-82853 is a medium-severity command injection vulnerability in nodemailer, published on 31 Aug 2026. An attacker needs administrator access to exploit it, with no action from the victim.

### Official description

Nodemailer versions before 8.0.5 contain an SMTP command injection vulnerability in the transport name option used in EHLO/HELO commands. The name parameter is concatenated directly into SMTP commands without sanitizing carriage return and line feed characters, allowing attackers to inject arbitrary SMTP commands for email spoofing and phishing attacks.

Weakness: CWE-93 (Improper Neutralization of CRLF Sequences)

## Which versions are affected by CVE-2026-82853?

2 open source packages ship an affected version, including nodemailer.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `nodemailer` | npm | All versions | 8.0.5 |
| `nodemailer` | npm | All versions | 8.0.5 |

## How do I fix CVE-2026-82853?

Upgrade nodemailer to 8.0.5 or later.

## Is CVE-2026-82853 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-82853 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-82853 and fix it if it is affected.

What it is: CVE-2026-82853 is a medium-severity command injection vulnerability in nodemailer, published on 31 Aug 2026. An attacker needs administrator access to exploit it, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-82853 exists.

Affected packages and fixed versions:
- nodemailer (npm): affected all versions; fixed in 8.0.5
- nodemailer (npm): affected all versions; fixed in 8.0.5

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-82853/ (Markdown: https://insights.sbomify.com/CVE-2026-82853/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-82853
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-82853
- OSV: https://osv.dev/vulnerability/CVE-2026-82853

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-82853/
Summaries are generated and may contain mistakes; the official description above is the record.
