{"answers":{"affected":"2 open source packages ship an affected version, including @hulumi/drift.","exploited":"There is no known exploitation of CVE-2026-82858 in the wild and no public exploit code.","fix":"Upgrade @hulumi/drift to 1.3.2 or later.","what":"CVE-2026-82858 is a critical vulnerability in hulumi drift, published on 31 Aug 2026. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2026-82858 and fix it if it is affected.\n\nWhat it is: CVE-2026-82858 is a critical vulnerability in hulumi drift, published on 31 Aug 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2026-82858 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- @hulumi/drift (npm): affected all versions; fixed in 1.3.2\n- @hulumi/drift (npm): affected all versions; fixed in 1.3.2\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2026-82858/ (Markdown: https://insights.sbomify.com/CVE-2026-82858/index.md)","id":"CVE-2026-82858","markdown":"https://insights.sbomify.com/CVE-2026-82858/index.md","name":"CVE-2026-82858","record":{"aliases":["GHSA-2ffm-hxrq-qqmm","GHSA-wpxp-22v5-r9cx"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["code_execution","security_bypass"],"network_reachable":"yes","non_default_config":false,"product_category":"Hulumi drift library","requires_auth":"none","summary":"Attackers can supply malicious execute plans to bypass security checks and perform unsafe reconciliation operations in the Hulumi drift library.","user_interaction":"not_required","vuln_class":"security_feature_bypass"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"VulnCheck","cpe":[],"cvss":{"score":9.3,"severity":"critical","source":"cna","vector":"CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N","version":"4.0"},"cwes":[{"id":"CWE-345","name":"Insufficient Verification of Data Authenticity"}],"description":"@hulumi/drift versions before 1.3.2 accept externally supplied execute plans without sufficient provenance validation, allowing untrusted reconciliation input to be treated as trusted. Attackers can supply malicious execute plans that bypass security checks to perform unsafe reconciliation operations.","ecosystems":["npm"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":false,"headline":"@hulumi/drift before 1.3.2 Unsafe Execute Plan Acceptance","id":"CVE-2026-82858","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"npm","product":null,"products":[],"type":"security_feature_bypass","year":"2026"},"n_packages":2,"n_references":2,"next":{"headline":"hulumi before v1.3.2 SCP Template Tag-on-Create Bypass","id":"CVE-2026-82859"},"packages":[{"ecosystem":"npm","fixed":["1.3.2"],"introduced":["0"],"last_affected":[],"package":"@hulumi/drift","purl":null,"source":"GHSA-2ffm-hxrq-qqmm"},{"ecosystem":"npm","fixed":["1.3.2"],"introduced":["0"],"last_affected":[],"package":"@hulumi/drift","purl":"pkg:npm/%40hulumi/drift","source":"GHSA-2ffm-hxrq-qqmm"}],"prev":{"headline":"hulumi before v1.3.2 Privilege Escalation via IAM Policy","id":"CVE-2026-82857"},"products":["drift"],"published":"2026-08-31","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"yes","exploitation":"none","technical_impact":"total"},"state":"PUBLISHED","updated":"2026-10-08","vendors":["hulumi"]},"summary":"Attackers can supply malicious execute plans to bypass security checks and perform unsafe reconciliation operations in the Hulumi drift library.","url":"https://insights.sbomify.com/CVE-2026-82858/"}