# CVE-2026-82860: @hulumi/policies before 1.3.2 Admin Policy Bypass

> Attackers can bypass admin policy guardrails in Hulumi policies by crafting admin-equivalent IAM paths, leading to privilege escalation.

- **Severity:** Critical 9.3 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** No
- **Published:** 31 Aug 2026
- **Updated:** 8 Oct 2026
- **Also known as:** GHSA-4xrh-5m3m-328w, GHSA-9pm9-rvf2-mhqv

## What is CVE-2026-82860?

CVE-2026-82860 is a critical missing authorization vulnerability in hulumi policies, published on 31 Aug 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

@hulumi/policies versions before 1.3.2 fail to fully inspect inline and attached IAM policy evidence for the administrator-policy guardrail. Attackers can craft admin-equivalent policy paths that bypass policy evaluation controls.

Weakness: CWE-269 (Improper Privilege Management)

## Which versions are affected by CVE-2026-82860?

2 open source packages ship an affected version, including @hulumi/policies.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `@hulumi/policies` | npm | All versions | 1.3.2 |
| `@hulumi/policies` | npm | All versions | 1.3.2 |

## How do I fix CVE-2026-82860?

Upgrade @hulumi/policies to 1.3.2 or later.

## Is CVE-2026-82860 being exploited?

There is no known exploitation of CVE-2026-82860 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-82860 and fix it if it is affected.

What it is: CVE-2026-82860 is a critical missing authorization vulnerability in hulumi policies, published on 31 Aug 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-82860 in the wild and no public exploit code.

Affected packages and fixed versions:
- @hulumi/policies (npm): affected all versions; fixed in 1.3.2
- @hulumi/policies (npm): affected all versions; fixed in 1.3.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-82860/ (Markdown: https://insights.sbomify.com/CVE-2026-82860/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-82860
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-82860
- OSV: https://osv.dev/vulnerability/CVE-2026-82860

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-82860/
Summaries are generated and may contain mistakes; the official description above is the record.
