# CVE-2026-82861: @hulumi/policies before 1.3.2 SecureBucket Parent Spoof Bypass

> Attackers can bypass SecureBucket policy checks by submitting spoofed parent evidence, allowing unsafe bucket configurations to pass validation.

- **Severity:** High 8.7 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:N/VA:N/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** No
- **Published:** 31 Aug 2026
- **Updated:** 8 Oct 2026
- **Also known as:** GHSA-5vxq-3j99-7xfc, GHSA-g43v-9x7q-83pq

## What is CVE-2026-82861?

CVE-2026-82861 is a high-severity vulnerability in hulumi policies, published on 31 Aug 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

@hulumi/policies versions before 1.3.2 contain a parent spoof bypass vulnerability that allows attackers to submit spoofed SecureBucket parent evidence during policy evaluation. Attackers can bypass security policy checks by providing falsified evidence, causing the validator to miss unsafe bucket configurations.

Weakness: CWE-284 (Improper Access Control)

## Which versions are affected by CVE-2026-82861?

2 open source packages ship an affected version, including @hulumi/policies.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `@hulumi/policies` | npm | All versions | 1.3.2 |
| `@hulumi/policies` | npm | All versions | 1.3.2 |

## How do I fix CVE-2026-82861?

Upgrade @hulumi/policies to 1.3.2 or later.

## Is CVE-2026-82861 being exploited?

There is no known exploitation of CVE-2026-82861 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-82861 and fix it if it is affected.

What it is: CVE-2026-82861 is a high-severity vulnerability in hulumi policies, published on 31 Aug 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-82861 in the wild and no public exploit code.

Affected packages and fixed versions:
- @hulumi/policies (npm): affected all versions; fixed in 1.3.2
- @hulumi/policies (npm): affected all versions; fixed in 1.3.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-82861/ (Markdown: https://insights.sbomify.com/CVE-2026-82861/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-82861
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-82861
- OSV: https://osv.dev/vulnerability/CVE-2026-82861

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-82861/
Summaries are generated and may contain mistakes; the official description above is the record.
