{"answers":{"affected":"2 open source packages ship an affected version, including @hulumi/baseline.","exploited":"There is no known exploitation of CVE-2026-82863 in the wild and no public exploit code.","fix":"Upgrade @hulumi/baseline to 1.3.2 or later.","what":"CVE-2026-82863 is a high-severity vulnerability in hulumi baseline, published on 31 Aug 2026. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2026-82863 and fix it if it is affected.\n\nWhat it is: CVE-2026-82863 is a high-severity vulnerability in hulumi baseline, published on 31 Aug 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2026-82863 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- @hulumi/baseline (npm): affected all versions; fixed in 1.3.2\n- @hulumi/baseline (npm): affected all versions; fixed in 1.3.2\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2026-82863/ (Markdown: https://insights.sbomify.com/CVE-2026-82863/index.md)","id":"CVE-2026-82863","markdown":"https://insights.sbomify.com/CVE-2026-82863/index.md","name":"CVE-2026-82863","record":{"aliases":["GHSA-5pxh-34gw-xxq6","GHSA-gfp8-mp24-5vxg"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["security_bypass"],"network_reachable":"yes","non_default_config":false,"product_category":"Cloud security library","requires_auth":"none","summary":"Attackers can modify CloudTrail event selectors without detection, evading audit trail monitoring in applications using the @hulumi/baseline library.","user_interaction":"not_required","vuln_class":"security_feature_bypass"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"VulnCheck","cpe":[],"cvss":{"score":8.7,"severity":"high","source":"cna","vector":"CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:N/VA:N/SC:N/SI:N/SA:N","version":"4.0"},"cwes":[{"id":"CWE-778","name":"Insufficient Logging"}],"description":"@hulumi/baseline versions before 1.3.2 fail to fully detect CloudTrail selector tampering events, reducing audit logging configuration change coverage. Attackers can modify CloudTrail event selectors without complete detection, potentially evading audit trail monitoring.","ecosystems":["npm"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":false,"headline":"@hulumi/baseline before 1.3.2 CloudTrail Selector Tampering Detection","id":"CVE-2026-82863","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"npm","product":null,"products":[],"type":"security_feature_bypass","year":"2026"},"n_packages":2,"n_references":2,"next":{"headline":"pdfme pdf-lib before 5.5.10 Denial of Service via Decompression Bomb","id":"CVE-2026-82864"},"packages":[{"ecosystem":"npm","fixed":["1.3.2"],"introduced":["0"],"last_affected":[],"package":"@hulumi/baseline","purl":null,"source":"GHSA-gfp8-mp24-5vxg"},{"ecosystem":"npm","fixed":["1.3.2"],"introduced":["0"],"last_affected":[],"package":"@hulumi/baseline","purl":"pkg:npm/%40hulumi/baseline","source":"GHSA-gfp8-mp24-5vxg"}],"prev":{"headline":"Hulumi before v1.3.2 Helper Script Shadowing via Workspace Files","id":"CVE-2026-82862"},"products":["baseline"],"published":"2026-08-31","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"yes","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2026-10-08","vendors":["hulumi"]},"summary":"Attackers can modify CloudTrail event selectors without detection, evading audit trail monitoring in applications using the @hulumi/baseline library.","url":"https://insights.sbomify.com/CVE-2026-82863/"}