# CVE-2026-82863: @hulumi/baseline before 1.3.2 CloudTrail Selector Tampering Detection

> Attackers can modify CloudTrail event selectors without detection, evading audit trail monitoring in applications using the @hulumi/baseline library.

- **Severity:** High 8.7 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:N/VA:N/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** No
- **Published:** 31 Aug 2026
- **Updated:** 8 Oct 2026
- **Also known as:** GHSA-5pxh-34gw-xxq6, GHSA-gfp8-mp24-5vxg

## What is CVE-2026-82863?

CVE-2026-82863 is a high-severity vulnerability in hulumi baseline, published on 31 Aug 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

@hulumi/baseline versions before 1.3.2 fail to fully detect CloudTrail selector tampering events, reducing audit logging configuration change coverage. Attackers can modify CloudTrail event selectors without complete detection, potentially evading audit trail monitoring.

Weakness: CWE-778 (Insufficient Logging)

## Which versions are affected by CVE-2026-82863?

2 open source packages ship an affected version, including @hulumi/baseline.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `@hulumi/baseline` | npm | All versions | 1.3.2 |
| `@hulumi/baseline` | npm | All versions | 1.3.2 |

## How do I fix CVE-2026-82863?

Upgrade @hulumi/baseline to 1.3.2 or later.

## Is CVE-2026-82863 being exploited?

There is no known exploitation of CVE-2026-82863 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-82863 and fix it if it is affected.

What it is: CVE-2026-82863 is a high-severity vulnerability in hulumi baseline, published on 31 Aug 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-82863 in the wild and no public exploit code.

Affected packages and fixed versions:
- @hulumi/baseline (npm): affected all versions; fixed in 1.3.2
- @hulumi/baseline (npm): affected all versions; fixed in 1.3.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-82863/ (Markdown: https://insights.sbomify.com/CVE-2026-82863/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-82863
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-82863
- OSV: https://osv.dev/vulnerability/CVE-2026-82863

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-82863/
Summaries are generated and may contain mistakes; the official description above is the record.
