{"answers":{"affected":"2 open source packages ship an affected version, including @pdfme/pdf-lib.","exploited":"There is no known exploitation of CVE-2026-82864 in the wild and no public exploit code.","fix":"Upgrade @pdfme/pdf-lib to 5.5.10 or later.","what":"CVE-2026-82864 is a high-severity denial of service vulnerability in pdfme pdf-lib, published on 31 Aug 2026. Any signed-in user can exploit it over the network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2026-82864 and fix it if it is affected.\n\nWhat it is: CVE-2026-82864 is a high-severity denial of service vulnerability in pdfme pdf-lib, published on 31 Aug 2026. Any signed-in user can exploit it over the network, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2026-82864 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- @pdfme/pdf-lib (npm): affected all versions; fixed in 5.5.10\n- @pdfme/pdf-lib (npm): affected all versions; fixed in 5.5.10\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2026-82864/ (Markdown: https://insights.sbomify.com/CVE-2026-82864/index.md)","id":"CVE-2026-82864","markdown":"https://insights.sbomify.com/CVE-2026-82864/index.md","name":"CVE-2026-82864","record":{"aliases":["GHSA-gvgq-37w5-4f8q","GHSA-vrqm-gvq7-rrwh"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["denial_of_service"],"network_reachable":"yes","non_default_config":false,"product_category":"JavaScript PDF library","requires_auth":"low_privilege","summary":"Attackers can cause denial of service by uploading crafted PDFs that trigger unbounded memory growth during decompression, crashing the application.","user_interaction":"not_required","vuln_class":"denial_of_service"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"VulnCheck","cpe":[],"cvss":{"score":7.1,"severity":"high","source":"cna","vector":"CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:N/VI:N/VA:H/SC:N/SI:N/SA:N","version":"4.0"},"cwes":[{"id":"CWE-409","name":"Improper Handling of Highly Compressed Data (Data Amplification)"}],"description":"pdfme pdf-lib versions before 5.5.10 contain an unbounded buffer growth vulnerability in the DecodeStream.ensureBuffer() method that allows attackers to cause denial of service by supplying a crafted PDF with a FlateDecode stream containing a decompression bomb. Attackers can upload a small compressed PDF that decompresses to hundreds of megabytes, exhausting memory and crashing the Node.js process or freezing browser tabs during PDF parsing.","ecosystems":["npm"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":false,"headline":"pdfme pdf-lib before 5.5.10 Denial of Service via Decompression Bomb","id":"CVE-2026-82864","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"npm","product":null,"products":[],"type":"denial_of_service","year":"2026"},"n_packages":2,"n_references":2,"next":{"headline":"pdfme schemas before 5.5.10 Cross-Site Scripting via i18n Label","id":"CVE-2026-82865"},"packages":[{"ecosystem":"npm","fixed":["5.5.10"],"introduced":["0"],"last_affected":[],"package":"@pdfme/pdf-lib","purl":null,"source":"GHSA-vrqm-gvq7-rrwh"},{"ecosystem":"npm","fixed":["5.5.10"],"introduced":["0"],"last_affected":[],"package":"@pdfme/pdf-lib","purl":"pkg:npm/%40pdfme/pdf-lib","source":"GHSA-vrqm-gvq7-rrwh"}],"prev":{"headline":"@hulumi/baseline before 1.3.2 CloudTrail Selector Tampering Detection","id":"CVE-2026-82863"},"products":["pdf-lib"],"published":"2026-08-31","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2026-10-08","vendors":["pdfme"]},"summary":"Attackers can cause denial of service by uploading crafted PDFs that trigger unbounded memory growth during decompression, crashing the application.","url":"https://insights.sbomify.com/CVE-2026-82864/"}