{"answers":{"affected":"2 open source packages ship an affected version, including @pdfme/schemas.","exploited":"It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-82865 exists.","fix":"Upgrade @pdfme/schemas to 5.5.10 or later.","what":"CVE-2026-82865 is a low-severity cross-site scripting vulnerability in pdfme schemas, published on 31 Aug 2026. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2026-82865 and fix it if it is affected.\n\nWhat it is: CVE-2026-82865 is a low-severity cross-site scripting vulnerability in pdfme schemas, published on 31 Aug 2026. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.\nExploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-82865 exists.\n\nAffected packages and fixed versions:\n- @pdfme/schemas (npm): affected all versions; fixed in 5.5.10\n- @pdfme/schemas (npm): affected all versions; fixed in 5.5.10\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2026-82865/ (Markdown: https://insights.sbomify.com/CVE-2026-82865/index.md)","id":"CVE-2026-82865","markdown":"https://insights.sbomify.com/CVE-2026-82865/index.md","name":"CVE-2026-82865","record":{"aliases":["GHSA-v7hf-w8f6-4v98","GHSA-xgx4-2wgv-4jhm"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["code_execution"],"network_reachable":"yes","non_default_config":false,"product_category":"pdfme schemas library","requires_auth":"low_privilege","summary":"Attackers can inject arbitrary JavaScript via unsanitized i18n labels in pdfme schemas, leading to code execution when users interact with specific fields.","user_interaction":"required","vuln_class":"xss"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"VulnCheck","cpe":[],"cvss":{"score":2.1,"severity":"low","source":"cna","vector":"CVSS:4.0/AV:N/AC:H/AT:P/PR:L/UI:P/VC:L/VI:L/VA:N/SC:L/SI:L/SA:N","version":"4.0"},"cwes":[{"id":"CWE-79","name":"Improper Neutralization of Input During Web Page Generation"}],"description":"pdfme schemas before 5.5.10 contains a cross-site scripting vulnerability in the multiVariableText property panel that assigns unsanitized i18n label values to innerHTML. Attackers who control label overrides through options.labels can inject arbitrary JavaScript that executes when users open the Designer and select a multiVariableText field without variable placeholders.","ecosystems":["npm"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"weaponised"},"has_fix":false,"headline":"pdfme schemas before 5.5.10 Cross-Site Scripting via i18n Label","id":"CVE-2026-82865","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"npm","product":null,"products":[],"type":"xss","year":"2026"},"n_packages":2,"n_references":2,"next":{"headline":"@pdfme/common before 5.5.10 SSRF via Unvalidated URL Fetch","id":"CVE-2026-82866"},"packages":[{"ecosystem":"npm","fixed":["5.5.10"],"introduced":["0"],"last_affected":[],"package":"@pdfme/schemas","purl":null,"source":"GHSA-xgx4-2wgv-4jhm"},{"ecosystem":"npm","fixed":["5.5.10"],"introduced":["0"],"last_affected":[],"package":"@pdfme/schemas","purl":"pkg:npm/%40pdfme/schemas","source":"GHSA-xgx4-2wgv-4jhm"}],"prev":{"headline":"pdfme pdf-lib before 5.5.10 Denial of Service via Decompression Bomb","id":"CVE-2026-82864"},"products":["schemas"],"published":"2026-08-31","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"poc","technical_impact":"partial"},"state":"PUBLISHED","updated":"2026-10-08","vendors":["pdfme"]},"summary":"Attackers can inject arbitrary JavaScript via unsanitized i18n labels in pdfme schemas, leading to code execution when users interact with specific fields.","url":"https://insights.sbomify.com/CVE-2026-82865/"}