# CVE-2026-82865: pdfme schemas before 5.5.10 Cross-Site Scripting via i18n Label

> Attackers can inject arbitrary JavaScript via unsanitized i18n labels in pdfme schemas, leading to code execution when users interact with specific fields.

- **Severity:** Low 2.1 (`CVSS:4.0/AV:N/AC:H/AT:P/PR:L/UI:P/VC:L/VI:L/VA:N/SC:L/SI:L/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** No
- **Published:** 31 Aug 2026
- **Updated:** 8 Oct 2026
- **Also known as:** GHSA-v7hf-w8f6-4v98, GHSA-xgx4-2wgv-4jhm

## What is CVE-2026-82865?

CVE-2026-82865 is a low-severity cross-site scripting vulnerability in pdfme schemas, published on 31 Aug 2026. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.

### Official description

pdfme schemas before 5.5.10 contains a cross-site scripting vulnerability in the multiVariableText property panel that assigns unsanitized i18n label values to innerHTML. Attackers who control label overrides through options.labels can inject arbitrary JavaScript that executes when users open the Designer and select a multiVariableText field without variable placeholders.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2026-82865?

2 open source packages ship an affected version, including @pdfme/schemas.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `@pdfme/schemas` | npm | All versions | 5.5.10 |
| `@pdfme/schemas` | npm | All versions | 5.5.10 |

## How do I fix CVE-2026-82865?

Upgrade @pdfme/schemas to 5.5.10 or later.

## Is CVE-2026-82865 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-82865 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-82865 and fix it if it is affected.

What it is: CVE-2026-82865 is a low-severity cross-site scripting vulnerability in pdfme schemas, published on 31 Aug 2026. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-82865 exists.

Affected packages and fixed versions:
- @pdfme/schemas (npm): affected all versions; fixed in 5.5.10
- @pdfme/schemas (npm): affected all versions; fixed in 5.5.10

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-82865/ (Markdown: https://insights.sbomify.com/CVE-2026-82865/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-82865
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-82865
- OSV: https://osv.dev/vulnerability/CVE-2026-82865

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-82865/
Summaries are generated and may contain mistakes; the official description above is the record.
