{"answers":{"affected":"2 open source packages ship an affected version, including @pdfme/common.","exploited":"It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-82866 exists.","fix":"Upgrade @pdfme/common to 5.5.10 or later.","what":"CVE-2026-82866 is a high-severity server-side request forgery vulnerability in pdfme common, published on 31 Aug 2026. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2026-82866 and fix it if it is affected.\n\nWhat it is: CVE-2026-82866 is a high-severity server-side request forgery vulnerability in pdfme common, published on 31 Aug 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-82866 exists.\n\nAffected packages and fixed versions:\n- @pdfme/common (npm): affected all versions; fixed in 5.5.10\n- @pdfme/common (npm): affected all versions; fixed in 5.5.10\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2026-82866/ (Markdown: https://insights.sbomify.com/CVE-2026-82866/index.md)","id":"CVE-2026-82866","markdown":"https://insights.sbomify.com/CVE-2026-82866/index.md","name":"CVE-2026-82866","record":{"aliases":["GHSA-4jj6-4ggm-xjcj","GHSA-pgx6-7jcq-2qff"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["data_read","security_bypass"],"network_reachable":"yes","non_default_config":false,"product_category":"PDF generation library","requires_auth":"none","summary":"Attackers can force servers to fetch arbitrary internal URLs via unvalidated basePdf templates, enabling metadata exfiltration and network reconnaissance.","user_interaction":"not_required","vuln_class":"ssrf"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"VulnCheck","cpe":[],"cvss":{"score":8.9,"severity":"high","source":"cna","vector":"CVSS:4.0/AV:N/AC:H/AT:P/PR:N/UI:N/VC:H/VI:N/VA:N/SC:H/SI:N/SA:N","version":"4.0"},"cwes":[{"id":"CWE-918","name":"Server-Side Request Forgery"}],"description":"@pdfme/common before 5.5.10 contains a server-side request forgery vulnerability in the getB64BasePdf function that fetches arbitrary URLs without validation when basePdf is attacker-controlled. Attackers who control the basePdf template field can force servers or clients to make requests to internal endpoints, enabling metadata exfiltration, network reconnaissance, and blind request forgery attacks.","ecosystems":["npm"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"weaponised"},"has_fix":false,"headline":"@pdfme/common before 5.5.10 SSRF via Unvalidated URL Fetch","id":"CVE-2026-82866","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"npm","product":null,"products":[],"type":"ssrf","year":"2026"},"n_packages":2,"n_references":2,"next":{"headline":"@pdfme/schemas before 5.5.9 Cross-Site Scripting via Select","id":"CVE-2026-82867"},"packages":[{"ecosystem":"npm","fixed":["5.5.10"],"introduced":["0"],"last_affected":[],"package":"@pdfme/common","purl":null,"source":"GHSA-pgx6-7jcq-2qff"},{"ecosystem":"npm","fixed":["5.5.10"],"introduced":["0"],"last_affected":[],"package":"@pdfme/common","purl":"pkg:npm/%40pdfme/common","source":"GHSA-pgx6-7jcq-2qff"}],"prev":{"headline":"pdfme schemas before 5.5.10 Cross-Site Scripting via i18n Label","id":"CVE-2026-82865"},"products":["common"],"published":"2026-08-31","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"poc","technical_impact":"partial"},"state":"PUBLISHED","updated":"2026-10-08","vendors":["pdfme"]},"summary":"Attackers can force servers to fetch arbitrary internal URLs via unvalidated basePdf templates, enabling metadata exfiltration and network reconnaissance.","url":"https://insights.sbomify.com/CVE-2026-82866/"}