# CVE-2026-82866: @pdfme/common before 5.5.10 SSRF via Unvalidated URL Fetch

> Attackers can force servers to fetch arbitrary internal URLs via unvalidated basePdf templates, enabling metadata exfiltration and network reconnaissance.

- **Severity:** High 8.9 (`CVSS:4.0/AV:N/AC:H/AT:P/PR:N/UI:N/VC:H/VI:N/VA:N/SC:H/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** No
- **Published:** 31 Aug 2026
- **Updated:** 8 Oct 2026
- **Also known as:** GHSA-4jj6-4ggm-xjcj, GHSA-pgx6-7jcq-2qff

## What is CVE-2026-82866?

CVE-2026-82866 is a high-severity server-side request forgery vulnerability in pdfme common, published on 31 Aug 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

@pdfme/common before 5.5.10 contains a server-side request forgery vulnerability in the getB64BasePdf function that fetches arbitrary URLs without validation when basePdf is attacker-controlled. Attackers who control the basePdf template field can force servers or clients to make requests to internal endpoints, enabling metadata exfiltration, network reconnaissance, and blind request forgery attacks.

Weakness: CWE-918 (Server-Side Request Forgery)

## Which versions are affected by CVE-2026-82866?

2 open source packages ship an affected version, including @pdfme/common.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `@pdfme/common` | npm | All versions | 5.5.10 |
| `@pdfme/common` | npm | All versions | 5.5.10 |

## How do I fix CVE-2026-82866?

Upgrade @pdfme/common to 5.5.10 or later.

## Is CVE-2026-82866 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-82866 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-82866 and fix it if it is affected.

What it is: CVE-2026-82866 is a high-severity server-side request forgery vulnerability in pdfme common, published on 31 Aug 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-82866 exists.

Affected packages and fixed versions:
- @pdfme/common (npm): affected all versions; fixed in 5.5.10
- @pdfme/common (npm): affected all versions; fixed in 5.5.10

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-82866/ (Markdown: https://insights.sbomify.com/CVE-2026-82866/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-82866
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-82866
- OSV: https://osv.dev/vulnerability/CVE-2026-82866

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-82866/
Summaries are generated and may contain mistakes; the official description above is the record.
