{"answers":{"affected":"2 open source packages ship an affected version, including @pdfme/schemas.","exploited":"It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-82867 exists.","fix":"Upgrade @pdfme/schemas to 5.5.9 or later.","what":"CVE-2026-82867 is a medium-severity cross-site scripting vulnerability in pdfme schemas, published on 31 Aug 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2026-82867 and fix it if it is affected.\n\nWhat it is: CVE-2026-82867 is a medium-severity cross-site scripting vulnerability in pdfme schemas, published on 31 Aug 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.\nExploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-82867 exists.\n\nAffected packages and fixed versions:\n- @pdfme/schemas (npm): affected all versions; fixed in 5.5.9\n- @pdfme/schemas (npm): affected all versions; fixed in 5.5.9\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2026-82867/ (Markdown: https://insights.sbomify.com/CVE-2026-82867/index.md)","id":"CVE-2026-82867","markdown":"https://insights.sbomify.com/CVE-2026-82867/index.md","name":"CVE-2026-82867","record":{"aliases":["GHSA-q78q-xrxw-xgx6","GHSA-qq9g-96v4-m3cj"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["code_execution"],"network_reachable":"yes","non_default_config":false,"product_category":"PDF schema library","requires_auth":"none","summary":"Attackers can execute arbitrary JavaScript in users' browsers by supplying malicious templates with unsanitized option values in the Select schema plugin.","user_interaction":"required","vuln_class":"xss"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"VulnCheck","cpe":[],"cvss":{"score":5.3,"severity":"medium","source":"cna","vector":"CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:P/VC:L/VI:L/VA:N/SC:L/SI:L/SA:N","version":"4.0"},"cwes":[{"id":"CWE-79","name":"Improper Neutralization of Input During Web Page Generation"}],"description":"@pdfme/schemas before 5.5.9 contains a cross-site scripting vulnerability in the Select schema plugin that fails to sanitize option values before interpolating them into HTML via innerHTML. Attackers can supply malicious templates with crafted option values containing HTML and JavaScript to execute arbitrary code in users' browsers.","ecosystems":["npm"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"weaponised"},"has_fix":false,"headline":"@pdfme/schemas before 5.5.9 Cross-Site Scripting via Select","id":"CVE-2026-82867","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"npm","product":null,"products":[],"type":"xss","year":"2026"},"n_packages":2,"n_references":2,"next":{"headline":"@pdfme/schemas before 5.5.9 Cross-Site Scripting via SVG","id":"CVE-2026-82868"},"packages":[{"ecosystem":"npm","fixed":["5.5.9"],"introduced":["0"],"last_affected":[],"package":"@pdfme/schemas","purl":null,"source":"GHSA-qq9g-96v4-m3cj"},{"ecosystem":"npm","fixed":["5.5.9"],"introduced":["0"],"last_affected":[],"package":"@pdfme/schemas","purl":"pkg:npm/%40pdfme/schemas","source":"GHSA-qq9g-96v4-m3cj"}],"prev":{"headline":"@pdfme/common before 5.5.10 SSRF via Unvalidated URL Fetch","id":"CVE-2026-82866"},"products":["schemas"],"published":"2026-08-31","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"poc","technical_impact":"partial"},"state":"PUBLISHED","updated":"2026-10-08","vendors":["pdfme"]},"summary":"Attackers can execute arbitrary JavaScript in users' browsers by supplying malicious templates with unsanitized option values in the Select schema plugin.","url":"https://insights.sbomify.com/CVE-2026-82867/"}