# CVE-2026-82868: @pdfme/schemas before 5.5.9 Cross-Site Scripting via SVG

> Attackers can execute arbitrary JavaScript in users' browsers by injecting malicious SVG content into PDF templates using the @pdfme/schemas library.

- **Severity:** Medium 5.3 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:P/VC:L/VI:L/VA:N/SC:L/SI:L/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** No
- **Published:** 31 Aug 2026
- **Updated:** 8 Oct 2026
- **Also known as:** GHSA-87v3-4cfp-cm76, GHSA-9f44-gwhq-mr2g

## What is CVE-2026-82868?

CVE-2026-82868 is a medium-severity cross-site scripting vulnerability in pdfme schemas, published on 31 Aug 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

@pdfme/schemas before 5.5.9 contains a cross-site scripting vulnerability in the SVG schema plugin that renders user-supplied SVG content directly to innerHTML without sanitization. Attackers can inject malicious SVG with embedded scripts, event handlers, or foreignObject elements to execute arbitrary JavaScript in users' browsers when viewing or filling templates.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2026-82868?

2 open source packages ship an affected version, including @pdfme/schemas.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `@pdfme/schemas` | npm | All versions | 5.5.9 |
| `@pdfme/schemas` | npm | All versions | 5.5.9 |

## How do I fix CVE-2026-82868?

Upgrade @pdfme/schemas to 5.5.9 or later.

## Is CVE-2026-82868 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-82868 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-82868 and fix it if it is affected.

What it is: CVE-2026-82868 is a medium-severity cross-site scripting vulnerability in pdfme schemas, published on 31 Aug 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-82868 exists.

Affected packages and fixed versions:
- @pdfme/schemas (npm): affected all versions; fixed in 5.5.9
- @pdfme/schemas (npm): affected all versions; fixed in 5.5.9

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-82868/ (Markdown: https://insights.sbomify.com/CVE-2026-82868/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-82868
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-82868
- OSV: https://osv.dev/vulnerability/CVE-2026-82868

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-82868/
Summaries are generated and may contain mistakes; the official description above is the record.
