CVE-2026-8336 Post-authentication use-after-free error in $_internalJsEmit and mapreduce commands

High 7.7 Published Updated

An authenticated user can crash the MongoDB server via a use-after-free error in JavaScript execution commands, causing denial of service.

Exploited in the wild
Not known
Login needed
Any signed-in user
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2026-8336?

CVE-2026-8336 is a high-severity use after free vulnerability in Mongodb Mongodb, published on 13 May 2026. Any signed-in user can exploit it over the network, with no action from the victim.

Official description

After invoking $_internalJsEmit, which is not intended to be directly accessible, or mapreduce command’s map function in a certain way, an authenticated user can subsequently crash mongod when the server-side JavaScript engine (through $where, $function, mapreduce reduce stage, etc.) is used also in a specific way, resulting in a post-authentication denial-of-service.

This issue impacts MongoDB Server v8.2 versions prior to 8.2.9 and v8.3 versions prior to 8.3.2.

Weakness: CWE-416

Which versions are affected by CVE-2026-8336?

1 open source package ship an affected version, including mongodb. It affects 1 product.

PackageAffectedFixed in
mongodb BitnamiFrom 8.2.08.2.9, 8.3.2

Products include Mongodb Mongodb.

How do I fix CVE-2026-8336?

Upgrade mongodb to a fixed version for your release line: 8.2.9 or 8.3.2.

Upgrade to the fixed version. These bugs are found with fuzzing and sanitisers and avoided by memory-safe languages. More about Use after free.

Is CVE-2026-8336 being exploited?

There is no known exploitation of CVE-2026-8336 in the wild and no public exploit code.

All Mongodb Mongodb vulnerabilities

Sources

Also known as BIT-mongodb-2026-8336, GHSA-5f8r-h2c3-xvqc, MINI-4f9m-h24f-rwp4.

Is CVE-2026-8336 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free