CVE-2026-83525 Incorrect operator (CWE-480) in the FetchSnapshot RPC handler in Apache Kafka from 2.8.0 before 4.2.2, and from 4.3.0 before 4.3.2 on all pl
- Exploited in the wild
- Not known
- Fix
- None listed
What is CVE-2026-83525?
CVE-2026-83525 is a vulnerability in Apache Kafka, published on 28 Oct 2026.
Official description
Incorrect operator (CWE-480) in the FetchSnapshot RPC handler in Apache Kafka from 2.8.0 before 4.2.2, and from 4.3.0 before 4.3.2 on all platforms allows an authenticated attacker with CLUSTER_ACTION privilege to cause a denial of service (controller process termination) via a crafted FetchSnapshotRequest with an empty topics array or a topic with no partitions.
Users are recommended to upgrade to version 4.2.2, 4.3.2, or 4.4.0, which fix this issue. Users on unsupported branches (4.1.x and earlier) should upgrade to 4.2.2 or later.
Weakness: CWE-480
Which versions are affected by CVE-2026-83525?
How do I fix CVE-2026-83525?
No fix has been published for CVE-2026-83525 yet. Limit exposure of the affected software until one is available.
Is CVE-2026-83525 being exploited?
There is no known exploitation of CVE-2026-83525 in the wild and no public exploit code.
Sources
Also known as GHSA-34hc-fwhq-c7v8, UBUNTU-CVE-2026-83525.