# CVE-2026-83525: Incorrect operator (CWE-480) in the FetchSnapshot RPC handler in Apache Kafka from 2.8.0 before 4.2.2, and from 4.3.0 before 4.3.2 on all pl


- **Severity:** Not scored
- **Exploited in the wild:** Not known
- **Fix available:** No
- **Published:** 28 Oct 2026
- **Updated:** 28 Oct 2026
- **Also known as:** GHSA-34hc-fwhq-c7v8, UBUNTU-CVE-2026-83525

## What is CVE-2026-83525?

CVE-2026-83525 is a vulnerability in Apache Kafka, published on 28 Oct 2026. 

### Official description

Incorrect operator (CWE-480) in the FetchSnapshot RPC handler
in Apache Kafka from 2.8.0 before 4.2.2, and from 4.3.0 before 4.3.2
on all platforms allows an authenticated attacker with
CLUSTER_ACTION privilege to cause a denial of service
(controller process termination) via a crafted
FetchSnapshotRequest with an empty topics array or a topic
with no partitions.

Users are recommended to upgrade to version 4.2.2, 4.3.2, or
4.4.0, which fix this issue. Users on unsupported branches
(4.1.x and earlier) should upgrade to 4.2.2 or later.

Weakness: CWE-480 (Use of Incorrect Operator)

## Which versions are affected by CVE-2026-83525?


## How do I fix CVE-2026-83525?

No fix has been published for CVE-2026-83525 yet. Limit exposure of the affected software until one is available.

## Is CVE-2026-83525 being exploited?

There is no known exploitation of CVE-2026-83525 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-83525 and fix it if it is affected.

What it is: CVE-2026-83525 is a vulnerability in Apache Kafka, published on 28 Oct 2026. 
Exploitation: There is no known exploitation of CVE-2026-83525 in the wild and no public exploit code.

Affected product: Apache Kafka. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-83525/ (Markdown: https://insights.sbomify.com/CVE-2026-83525/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-83525
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-83525
- OSV: https://osv.dev/vulnerability/CVE-2026-83525

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-83525/
Summaries are generated and may contain mistakes; the official description above is the record.
