# CVE-2026-83534: PostgreSQL Anonymizer: Privilege escalation to superuser via anon.anonymize_database_parallel()

> Table owners can escalate privileges to superuser and execute arbitrary code via the anonymize_database_parallel function in PostgreSQL Anonymizer.

- **Severity:** Medium 6.4 (`CVSS:3.1/AV:N/AC:H/PR:H/UI:R/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** An administrator
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** No
- **Published:** 6 Sep 2026
- **Updated:** 9 Sep 2026
- **Also known as:** GHSA-j8qw-c658-vr9r

## What is CVE-2026-83534?

CVE-2026-83534 is a medium-severity vulnerability in DALIBO PostgreSQL Anonymizer, published on 6 Sep 2026. An attacker needs administrator access to exploit it, and only if a user opens a file or follows a link.

### Official description

PostgreSQL Anonymizer contains a vulnerability in the anon.anonymize_database_parallel() function that allows the owner of a table to run arbitrary code with superuser privilege. The issue is fixed in PostgreSQL Anonymizer 3.2.0 and later versions

Weakness: CWE-250 (Execution with Unnecessary Privileges)

## Which versions are affected by CVE-2026-83534?


## How do I fix CVE-2026-83534?

No fix has been published for CVE-2026-83534 yet. Limit exposure of the affected software until one is available.

## Is CVE-2026-83534 being exploited?

There is no known exploitation of CVE-2026-83534 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-83534 and fix it if it is affected.

What it is: CVE-2026-83534 is a medium-severity vulnerability in DALIBO PostgreSQL Anonymizer, published on 6 Sep 2026. An attacker needs administrator access to exploit it, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2026-83534 in the wild and no public exploit code.

Affected product: DALIBO PostgreSQL Anonymizer. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-83534/ (Markdown: https://insights.sbomify.com/CVE-2026-83534/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-83534
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-83534
- OSV: https://osv.dev/vulnerability/CVE-2026-83534

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-83534/
Summaries are generated and may contain mistakes; the official description above is the record.
