CVE-2026-83557 jackson-databind omits java.lang.Comparable from DefaultBaseTypeLimitingValidator's unsafe base types
Attackers can instantiate arbitrary Comparable classes via polymorphic deserialization, potentially enabling path traversal or data access in applications using default validators.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2026-83557?
CVE-2026-83557 is a medium-severity unsafe deserialization vulnerability in FasterXML jackson-databind, published on 1 Sep 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
DefaultBaseTypeLimitingValidator is the PolymorphicTypeValidator applied automatically whenever @JsonTypeInfo is used without an explicitly configured custom validator. It denies polymorphic resolution only for a fixed set of "unsafe base types", and its isSafeSubType method returns true unconditionally for every base type outside that set. java.lang.Comparable was absent from the list despite being implemented by a very large fraction of JDK and application classes, comparable in breadth to java.io.Serializable, which is on the list for that reason. An application declaring an @JsonTypeInfo-annotated property or class with Comparable as its base type, and no custom PolymorphicTypeValidator, will accept a type identifier for essentially any class implementing Comparable. This yields an attacker-controlled object instantiation primitive; a demonstrated case constructs a java.io.File for an arbitrary attacker-chosen path, which becomes path-traversal-adjacent if the application subsequently calls path-sensitive methods on the value. No class implementing Comparable has been identified that yields code execution through deserialization alone. Global Default Typing via activateDefaultTyping is not affected, because that method structurally requires an explicit PolymorphicTypeValidator argument. This affects com.fasterxml.jackson.core:jackson-databind from 2.11.0 before 2.18.10, from 2.19.0 before 2.21.6, and from 2.22.0 before 2.22.2, and tools.jackson.core:jackson-databind from 3.0.0 before 3.1.6 and from 3.2.0 before 3.2.2. Users should upgrade to 2.18.10, 2.21.6, 2.22.2, 3.1.6, or 3.2.2.
Which versions are affected by CVE-2026-83557?
10 open source packages ship an affected version, including com.fasterxml.jackson.core:jackson-databind and tools.jackson.core:jackson-databind.
| Package | Affected | Fixed in |
|---|---|---|
com.fasterxml.jackson.core:jackson-databind Maven | From 2.11.0 | 2.18.10 |
com.fasterxml.jackson.core:jackson-databind Maven | From 2.11.0 | 2.18.10 |
com.fasterxml.jackson.core:jackson-databind Maven | From 2.19.0 | 2.21.6 |
com.fasterxml.jackson.core:jackson-databind Maven | From 2.19.0 | 2.21.6 |
com.fasterxml.jackson.core:jackson-databind Maven | From 2.22.0 | 2.22.2 |
com.fasterxml.jackson.core:jackson-databind Maven | From 2.22.0 | 2.22.2 |
4 more packages
tools.jackson.core:jackson-databind Maven | From 3.0.0 | 3.1.6 |
tools.jackson.core:jackson-databind Maven | From 3.0.0 | 3.1.6 |
tools.jackson.core:jackson-databind Maven | From 3.2.0 | 3.2.2 |
tools.jackson.core:jackson-databind Maven | From 3.2.0 | 3.2.2 |
How do I fix CVE-2026-83557?
Upgrade com.fasterxml.jackson.core:jackson-databind to a fixed version for your release line: 2.18.10, 2.21.6 or 2.22.2.
Upgrade, and only deserialise data from trusted sources or with an allow-list of types. More about Unsafe deserialization.
Is CVE-2026-83557 being exploited?
It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-83557 exists.
Sources
Also known as CLEANSTART-2026-BM20814, CLEANSTART-2026-CI22056, CLEANSTART-2026-DP01123, CLEANSTART-2026-HB03857, CLEANSTART-2026-HR33397, CLEANSTART-2026-HZ51336 and 125 more.