# CVE-2026-83601: Netdata: Streaming protocol dimension slot has no upper-bound guard, allowing integer overflow and out-of-bounds write

> An authenticated child agent can trigger an integer overflow leading to an out-of-bounds write, crashing the parent agent or potentially executing code.

- **Severity:** Medium 6.5 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 22 Sep 2026
- **Updated:** 25 Sep 2026
- **Also known as:** DEBIAN-CVE-2026-83601, GHSA-3qh4-842w-fvrm, MINI-fcj6-fxcp-xghc, MINI-vxhv-cghv-8hqh, UBUNTU-CVE-2026-83601

## What is CVE-2026-83601?

CVE-2026-83601 is a medium-severity vulnerability in netdata, published on 22 Sep 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Netdata is an open source observability tool. Prior to 2.10.4, an authenticated child agent can send an oversized DIMENSION SLOT value that str2ull_encoded passes to pluginsd_rrddim_put_to_slot in src/plugins.d/pluginsd_internals.h without an upper bound. prd_array_create in src/database/rrdset-pluginsd-array.h can then wrap the size_t allocation calculation while retaining the original large array size, causing the subsequent initialization loop to write beyond the undersized heap allocation and crash the parent agent. This issue is fixed in version 2.10.4 and nightly build 2.10.0-782-nightly.

Weakness: CWE-787 (Out-of-bounds Write), CWE-190 (Integer Overflow or Wraparound)

## Which versions are affected by CVE-2026-83601?


## How do I fix CVE-2026-83601?

Upgrade to a fixed version.

## Is CVE-2026-83601 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-83601 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-83601 and fix it if it is affected.

What it is: CVE-2026-83601 is a medium-severity vulnerability in netdata, published on 22 Sep 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-83601 exists.

Affected product: netdata. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-83601/ (Markdown: https://insights.sbomify.com/CVE-2026-83601/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-83601
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-83601
- OSV: https://osv.dev/vulnerability/CVE-2026-83601

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-83601/
Summaries are generated and may contain mistakes; the official description above is the record.
