# CVE-2026-83603: Netdata: Local Root via ndsudo Arbitrary socket_path → fail2ban-client Pickle RCE

> A local attacker can escalate privileges to root by manipulating a socket path to trigger unsafe deserialization in fail2ban-client via Netdata's ndsudo helper.

- **Severity:** High 8.4 (`CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:C/C:H/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Local or same network only
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 22 Sep 2026
- **Updated:** 22 Sep 2026
- **Also known as:** DEBIAN-CVE-2026-83603, GHSA-qwh9-pq27-993w, MINI-9355-ffhc-6gmq, MINI-p8jc-2842-wpwr, UBUNTU-CVE-2026-83603

## What is CVE-2026-83603?

CVE-2026-83603 is a high-severity unsafe deserialization vulnerability in netdata, published on 22 Sep 2026. It can only be exploited from the same machine or local network, with no action from the victim.

### Official description

Netdata is an open source observability tool. Prior to 2.10.4, the setuid-root ndsudo helper command fail2ban-client-status-socket in src/collectors/utils/ndsudo.c accepts a caller-controlled --socket_path from the low-privileged netdata service account. The account can direct root fail2ban-client to a malicious UNIX socket, and fail2ban/client/csocket.py CSocket.receive() passes the returned data to pickle.loads(), allowing attacker-controlled code to execute as root on systems with fail2ban-client installed. This issue is fixed in version 2.10.4 and nightly build 2.10.0-782-nightly.

Weakness: CWE-73 (External Control of File Name or Path), CWE-502 (Deserialization of Untrusted Data)

## Which versions are affected by CVE-2026-83603?


## How do I fix CVE-2026-83603?

Upgrade to a fixed version.

## Is CVE-2026-83603 being exploited?

There is no known exploitation of CVE-2026-83603 in the wild and no public exploit code.

Public exploit code:

- A PoC for ZDI-CAN-28834/CVE-2026-83603, which allows local privilege escalation using netdata and fail2ban-client (github_poc): https://github.com/OhWelp/CVE-2026-83603-LPE-PoC

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-83603 and fix it if it is affected.

What it is: CVE-2026-83603 is a high-severity unsafe deserialization vulnerability in netdata, published on 22 Sep 2026. It can only be exploited from the same machine or local network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-83603 in the wild and no public exploit code.

Affected product: netdata. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-83603/ (Markdown: https://insights.sbomify.com/CVE-2026-83603/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-83603
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-83603
- OSV: https://osv.dev/vulnerability/CVE-2026-83603

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-83603/
Summaries are generated and may contain mistakes; the official description above is the record.
