# CVE-2026-83606: xmldom PI grammar regex ReDoS: quadratic backtracking on unterminated processing instructions

> An attacker can cause a denial of service by sending a small, malformed XML input that triggers quadratic backtracking in the parser, stalling the application.

- **Severity:** High 8.7 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:N/VA:H/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 1 Sep 2026
- **Updated:** 1 Sep 2026
- **Also known as:** CLSA-2026-1791369737, DEBIAN-CVE-2026-83606, GHSA-g53g-w8rj-fmg7, UBUNTU-CVE-2026-83606

## What is CVE-2026-83606?

CVE-2026-83606 is a high-severity denial of service vulnerability in @xmldom xmldom, published on 1 Sep 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

xmldom is a pure JavaScript W3C standard-based (XML DOM Level 2 Core) DOMParser and XMLSerializer module. From 0.9.0-beta.9 until 0.9.11, the processing-instruction production in lib/grammar.js lets the greedy S+ separator and lazy Char*? data group repeatedly repartition a long whitespace tail when the required closing ?> is absent. Both parsePI and parseProcessingInstruction apply the expression to the entire remaining source, causing quadratic backtracking during DOMParser.parseFromString() under default options and allowing a small unauthenticated XML input to stall the Node.js event loop. This issue is fixed in @xmldom/xmldom version 0.9.11.

Weakness: CWE-400 (Uncontrolled Resource Consumption), CWE-1333 (Inefficient Regular Expression Complexity)

## Which versions are affected by CVE-2026-83606?

2 open source packages ship an affected version, including @xmldom/xmldom.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `@xmldom/xmldom` | npm | From 0.9.0-beta.9 | 0.9.11 |
| `@xmldom/xmldom` | npm | From 0.9.0-beta.9 | 0.9.11 |

## How do I fix CVE-2026-83606?

Upgrade @xmldom/xmldom to 0.9.11 or later.

## Is CVE-2026-83606 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-83606 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-83606 and fix it if it is affected.

What it is: CVE-2026-83606 is a high-severity denial of service vulnerability in @xmldom xmldom, published on 1 Sep 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-83606 exists.

Affected packages and fixed versions:
- @xmldom/xmldom (npm): affected from 0.9.0-beta.9; fixed in 0.9.11
- @xmldom/xmldom (npm): affected from 0.9.0-beta.9; fixed in 0.9.11

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-83606/ (Markdown: https://insights.sbomify.com/CVE-2026-83606/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-83606
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-83606
- OSV: https://osv.dev/vulnerability/CVE-2026-83606

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-83606/
Summaries are generated and may contain mistakes; the official description above is the record.
