CVE-2026-83607 xmldom: Element name injection via createElement() bypasses requireWellFormed
Attacker-controlled tag names in xmldom can inject malicious content into serialized XML, leading to cross-site scripting when consumed by browsers.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2026-83607?
CVE-2026-83607 is a high-severity cross-site scripting vulnerability in @xmldom xmldom, published on 1 Sep 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
xmldom is a pure JavaScript W3C standard-based (XML DOM Level 2 Core) DOMParser and XMLSerializer module. Prior to @xmldom/xmldom versions 0.8.14 and 0.9.11, and in xmldom version 0.6.0 and earlier, Document.createElement(tagName) stores an unvalidated element name and XMLSerializer.serializeToString() emits that name verbatim. The requireWellFormed: true path did not validate the element qualified name or synthesized xmlns:PREFIX declaration, so attacker-controlled tag names could inject attributes, elements, or processing instructions into serialized XML or HTML and could cause cross-site scripting when browser-consumed. The unchecked values violate the XML QName constraint, and default serialization and creation-time createElement() behavior remain permissive. This issue is fixed in @xmldom/xmldom versions 0.8.14 and 0.9.11; no fixed version is available for xmldom.
Weakness: CWE-91
Which versions are affected by CVE-2026-83607?
6 open source packages ship an affected version, including @xmldom/xmldom and xmldom.
| Package | Affected | Fixed in |
|---|---|---|
@xmldom/xmldom npm | From 0.7.0 | 0.8.14 |
@xmldom/xmldom npm | From 0.7.0 | 0.8.14 |
@xmldom/xmldom npm | From 0.9.0 | 0.9.11 |
@xmldom/xmldom npm | From 0.9.0 | 0.9.11 |
xmldom npm | All versions to 0.6.0 | None |
xmldom npm | All versions to 0.6.0 | None |
How do I fix CVE-2026-83607?
Upgrade @xmldom/xmldom to a fixed version for your release line: 0.8.14 or 0.9.11.
Escape output for the context it lands in and set a strict Content Security Policy. Upgrading the affected component is the real fix. More about Cross-site scripting.
Is CVE-2026-83607 being exploited?
It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-83607 exists.
Sources
Also known as AZL-99342, DEBIAN-CVE-2026-83607, ECHO-67f6-0b8a-4d08, GHSA-w2rr-34g9-rvrj, MINI-46pm-8445-cx5x, MINI-f54v-chrr-c33x and 4 more.