# CVE-2026-83607: xmldom: Element name injection via createElement() bypasses requireWellFormed

> Attacker-controlled tag names in xmldom can inject malicious content into serialized XML, leading to cross-site scripting when consumed by browsers.

- **Severity:** High 8.7 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:H/VA:N/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 1 Sep 2026
- **Updated:** 1 Sep 2026
- **Also known as:** AZL-99342, DEBIAN-CVE-2026-83607, ECHO-67f6-0b8a-4d08, GHSA-w2rr-34g9-rvrj, MINI-46pm-8445-cx5x, MINI-f54v-chrr-c33x, MINI-h8p5-9755-hp2f, MINI-wvrv-c473-c5hq, ROOT-APP-NPM-CVE-2026-83607, UBUNTU-CVE-2026-83607

## What is CVE-2026-83607?

CVE-2026-83607 is a high-severity cross-site scripting vulnerability in @xmldom xmldom, published on 1 Sep 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

xmldom is a pure JavaScript W3C standard-based (XML DOM Level 2 Core) DOMParser and XMLSerializer module. Prior to @xmldom/xmldom versions 0.8.14 and 0.9.11, and in xmldom version 0.6.0 and earlier, Document.createElement(tagName) stores an unvalidated element name and XMLSerializer.serializeToString() emits that name verbatim. The requireWellFormed: true path did not validate the element qualified name or synthesized xmlns:PREFIX declaration, so attacker-controlled tag names could inject attributes, elements, or processing instructions into serialized XML or HTML and could cause cross-site scripting when browser-consumed. The unchecked values violate the XML QName constraint, and default serialization and creation-time createElement() behavior remain permissive. This issue is fixed in @xmldom/xmldom versions 0.8.14 and 0.9.11; no fixed version is available for xmldom.

Weakness: CWE-91 (XML Injection)

## Which versions are affected by CVE-2026-83607?

6 open source packages ship an affected version, including @xmldom/xmldom and xmldom.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `@xmldom/xmldom` | npm | From 0.7.0 | 0.8.14 |
| `@xmldom/xmldom` | npm | From 0.7.0 | 0.8.14 |
| `@xmldom/xmldom` | npm | From 0.9.0 | 0.9.11 |
| `@xmldom/xmldom` | npm | From 0.9.0 | 0.9.11 |
| `xmldom` | npm | All versions to 0.6.0 | None |
| `xmldom` | npm | All versions to 0.6.0 | None |

## How do I fix CVE-2026-83607?

Upgrade @xmldom/xmldom to a fixed version for your release line: 0.8.14 or 0.9.11.

## Is CVE-2026-83607 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-83607 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-83607 and fix it if it is affected.

What it is: CVE-2026-83607 is a high-severity cross-site scripting vulnerability in @xmldom xmldom, published on 1 Sep 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-83607 exists.

Affected packages and fixed versions:
- @xmldom/xmldom (npm): affected from 0.7.0; fixed in 0.8.14
- @xmldom/xmldom (npm): affected from 0.7.0; fixed in 0.8.14
- @xmldom/xmldom (npm): affected from 0.9.0; fixed in 0.9.11
- @xmldom/xmldom (npm): affected from 0.9.0; fixed in 0.9.11
- xmldom (npm): affected all versions up to 0.6.0; no fix listed
- xmldom (npm): affected all versions up to 0.6.0; no fix listed

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-83607/ (Markdown: https://insights.sbomify.com/CVE-2026-83607/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-83607
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-83607
- OSV: https://osv.dev/vulnerability/CVE-2026-83607

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-83607/
Summaries are generated and may contain mistakes; the official description above is the record.
