# CVE-2026-83610: xmldom: XML fragment injection via invalid EntityReference.nodeName during requireWellFormed serialization

> Attackers can inject XML markup via invalid entity references in xmldom, potentially leading to code execution or data exposure if applications serialize these nodes.

- **Severity:** Medium 6.3 (`CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:N/VC:N/VI:L/VA:N/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 1 Sep 2026
- **Updated:** 3 Sep 2026
- **Also known as:** AZL-99339, CLEANSTART-2026-FD05711, CLSA-2026-1788561202, DEBIAN-CVE-2026-83610, ECHO-a905-3d03-0184, GHSA-6gmq-8vp8-gcm6, MINI-2h6h-hxcx-4g5f, MINI-6mcp-phrg-rwrp, MINI-856m-6cvr-w7xc, MINI-f5mx-wvqh-vvwx, UBUNTU-CVE-2026-83610

## What is CVE-2026-83610?

CVE-2026-83610 is a medium-severity vulnerability in @xmldom xmldom, published on 1 Sep 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

xmldom is a pure JavaScript W3C standard-based (XML DOM Level 2 Core) DOMParser and XMLSerializer module. Prior to @xmldom/xmldom versions 0.8.15 and 0.9.12, and in xmldom version 0.6.0 and earlier, Document.createEntityReference(name) accepts an invalid name and the ENTITY_REFERENCE_NODE serializer emits the resulting nodeName directly in &name; form. Directly serializing the node or fragment with XMLSerializer.serializeToString() and requireWellFormed: true can therefore break the entity-reference boundary and produce attacker-controlled XML markup when reparsed. The parser does not ordinarily create these nodes, and element-child insertion is rejected, so exploitation requires an application to create and directly serialize an EntityReference. This issue is fixed in @xmldom/xmldom versions 0.8.15 and 0.9.12; no fixed version is available for xmldom.

Weakness: CWE-116 (Improper Encoding or Escaping of Output)

## Which versions are affected by CVE-2026-83610?

6 open source packages ship an affected version, including @xmldom/xmldom and xmldom.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `@xmldom/xmldom` | npm | From 0.7.0 | 0.8.15 |
| `@xmldom/xmldom` | npm | From 0.7.0 | 0.8.15 |
| `@xmldom/xmldom` | npm | From 0.9.0 | 0.9.12 |
| `@xmldom/xmldom` | npm | From 0.9.0 | 0.9.12 |
| `xmldom` | npm | All versions to 0.6.0 | None |
| `xmldom` | npm | All versions to 0.6.0 | None |

## How do I fix CVE-2026-83610?

Upgrade @xmldom/xmldom to a fixed version for your release line: 0.8.15 or 0.9.12.

## Is CVE-2026-83610 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-83610 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-83610 and fix it if it is affected.

What it is: CVE-2026-83610 is a medium-severity vulnerability in @xmldom xmldom, published on 1 Sep 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-83610 exists.

Affected packages and fixed versions:
- @xmldom/xmldom (npm): affected from 0.7.0; fixed in 0.8.15
- @xmldom/xmldom (npm): affected from 0.7.0; fixed in 0.8.15
- @xmldom/xmldom (npm): affected from 0.9.0; fixed in 0.9.12
- @xmldom/xmldom (npm): affected from 0.9.0; fixed in 0.9.12
- xmldom (npm): affected all versions up to 0.6.0; no fix listed
- xmldom (npm): affected all versions up to 0.6.0; no fix listed

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-83610/ (Markdown: https://insights.sbomify.com/CVE-2026-83610/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-83610
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-83610
- OSV: https://osv.dev/vulnerability/CVE-2026-83610

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-83610/
Summaries are generated and may contain mistakes; the official description above is the record.
