CVE-2026-83611 xmldom: Parser silently accepts a not-well-formed end tag whose name is followed by a line break and trailing content
Attackers can bypass well-formedness validation gates in applications using xmldom by exploiting a parser differential that silently accepts malformed end tags.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2026-83611?
CVE-2026-83611 is a medium-severity vulnerability in @xmldom xmldom, published on 1 Sep 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
xmldom is a pure JavaScript W3C standard-based (XML DOM Level 2 Core) DOMParser and XMLSerializer module. Prior to @xmldom/xmldom versions 0.8.15 and 0.9.12, and in xmldom version 0.6.0 and earlier, DOMParser.parseFromString() can silently accept an end tag such as </a\njunk>, close the element, and discard the trailing content. On 0.9.x, the lib/sax.js end-tag validator inherits the multiline flag from reg(), allowing the first line to satisfy the anchored XML ETag production; older lines have no equivalent residue validation. This parser differential can bypass a parse-before-trust well-formedness gate, although it does not inject the discarded content; onError on 0.9.x and errorHandler on 0.8.x are the relevant reporting interfaces. This issue is fixed in @xmldom/xmldom versions 0.8.15 and 0.9.12; no fixed version is available for xmldom.
Weakness: CWE-1286
Which versions are affected by CVE-2026-83611?
6 open source packages ship an affected version, including @xmldom/xmldom and xmldom.
| Package | Affected | Fixed in |
|---|---|---|
@xmldom/xmldom npm | From 0.7.0 | 0.8.15 |
@xmldom/xmldom npm | From 0.7.0 | 0.8.15 |
@xmldom/xmldom npm | From 0.9.0 | 0.9.12 |
@xmldom/xmldom npm | From 0.9.0 | 0.9.12 |
xmldom npm | All versions to 0.6.0 | None |
xmldom npm | All versions to 0.6.0 | None |
How do I fix CVE-2026-83611?
Upgrade @xmldom/xmldom to a fixed version for your release line: 0.8.15 or 0.9.12.
Is CVE-2026-83611 being exploited?
It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-83611 exists.
Sources
Also known as AZL-99363, CLEANSTART-2026-UU21916, DEBIAN-CVE-2026-83611, ECHO-d5f2-8667-21d1, GHSA-6h8r-xr42-gp59, MINI-277x-p334-j7xh and 4 more.