# CVE-2026-83611: xmldom: Parser silently accepts a not-well-formed end tag whose name is followed by a line break and trailing content

> Attackers can bypass well-formedness validation gates in applications using xmldom by exploiting a parser differential that silently accepts malformed end tags.

- **Severity:** Medium 6.9 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:L/VA:N/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 1 Sep 2026
- **Updated:** 1 Sep 2026
- **Also known as:** AZL-99363, CLEANSTART-2026-UU21916, DEBIAN-CVE-2026-83611, ECHO-d5f2-8667-21d1, GHSA-6h8r-xr42-gp59, MINI-277x-p334-j7xh, MINI-6m98-vvrw-xf4w, MINI-7pgh-4vfx-jg57, MINI-hh7c-xh7f-h3mg, UBUNTU-CVE-2026-83611

## What is CVE-2026-83611?

CVE-2026-83611 is a medium-severity vulnerability in @xmldom xmldom, published on 1 Sep 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

xmldom is a pure JavaScript W3C standard-based (XML DOM Level 2 Core) DOMParser and XMLSerializer module. Prior to @xmldom/xmldom versions 0.8.15 and 0.9.12, and in xmldom version 0.6.0 and earlier, DOMParser.parseFromString() can silently accept an end tag such as </a\njunk>, close the element, and discard the trailing content. On 0.9.x, the lib/sax.js end-tag validator inherits the multiline flag from reg(), allowing the first line to satisfy the anchored XML ETag production; older lines have no equivalent residue validation. This parser differential can bypass a parse-before-trust well-formedness gate, although it does not inject the discarded content; onError on 0.9.x and errorHandler on 0.8.x are the relevant reporting interfaces. This issue is fixed in @xmldom/xmldom versions 0.8.15 and 0.9.12; no fixed version is available for xmldom.

Weakness: CWE-1286 (Improper Validation of Syntactic Correctness of Input)

## Which versions are affected by CVE-2026-83611?

6 open source packages ship an affected version, including @xmldom/xmldom and xmldom.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `@xmldom/xmldom` | npm | From 0.7.0 | 0.8.15 |
| `@xmldom/xmldom` | npm | From 0.7.0 | 0.8.15 |
| `@xmldom/xmldom` | npm | From 0.9.0 | 0.9.12 |
| `@xmldom/xmldom` | npm | From 0.9.0 | 0.9.12 |
| `xmldom` | npm | All versions to 0.6.0 | None |
| `xmldom` | npm | All versions to 0.6.0 | None |

## How do I fix CVE-2026-83611?

Upgrade @xmldom/xmldom to a fixed version for your release line: 0.8.15 or 0.9.12.

## Is CVE-2026-83611 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-83611 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-83611 and fix it if it is affected.

What it is: CVE-2026-83611 is a medium-severity vulnerability in @xmldom xmldom, published on 1 Sep 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-83611 exists.

Affected packages and fixed versions:
- @xmldom/xmldom (npm): affected from 0.7.0; fixed in 0.8.15
- @xmldom/xmldom (npm): affected from 0.7.0; fixed in 0.8.15
- @xmldom/xmldom (npm): affected from 0.9.0; fixed in 0.9.12
- @xmldom/xmldom (npm): affected from 0.9.0; fixed in 0.9.12
- xmldom (npm): affected all versions up to 0.6.0; no fix listed
- xmldom (npm): affected all versions up to 0.6.0; no fix listed

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-83611/ (Markdown: https://insights.sbomify.com/CVE-2026-83611/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-83611
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-83611
- OSV: https://osv.dev/vulnerability/CVE-2026-83611

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-83611/
Summaries are generated and may contain mistakes; the official description above is the record.
