CVE-2026-83614 xmldom: Quadratic-time parsing via the malformed-input recovery path — `parseElementStartPart` re-scan and `normalize()` adjacent-text merge
Attackers can cause denial of service in applications using xmldom by submitting malformed XML that triggers quadratic-time parsing and normalization loops.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2026-83614?
CVE-2026-83614 is a high-severity denial of service vulnerability in @xmldom xmldom, published on 1 Sep 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
xmldom is a pure JavaScript W3C standard-based (XML DOM Level 2 Core) DOMParser and XMLSerializer module. Prior to @xmldom/xmldom versions 0.8.15 and 0.9.12, and in xmldom versions 0.3.0 through 0.6.0, two independent quadratic paths can cause denial of service. In lib/sax.js, parseElementStartPart repeatedly rescans a malformed tag name to the next > during single-character recovery; in lib/dom.js, normalize() repeatedly removes and appends adjacent text nodes, causing quadratic reindexing and string rebuilding. The first path is reachable through default DOMParser.parseFromString() processing, while the second is also reachable through a direct normalize() call on a programmatically constructed DOM, and endDocument invokes that normalization after parsing. This issue is fixed in @xmldom/xmldom versions 0.8.15 and 0.9.12; no fixed version is available for xmldom.
Which versions are affected by CVE-2026-83614?
6 open source packages ship an affected version, including @xmldom/xmldom and xmldom.
| Package | Affected | Fixed in |
|---|---|---|
@xmldom/xmldom npm | From 0.7.0 | 0.8.15 |
@xmldom/xmldom npm | From 0.7.0 | 0.8.15 |
@xmldom/xmldom npm | From 0.9.0 | 0.9.12 |
@xmldom/xmldom npm | From 0.9.0 | 0.9.12 |
xmldom npm | From 0.3.0 to 0.6.0 | None |
xmldom npm | From 0.3.0 to 0.6.0 | None |
How do I fix CVE-2026-83614?
Upgrade @xmldom/xmldom to a fixed version for your release line: 0.8.15 or 0.9.12.
Upgrade, then put limits on request size, rate and nesting depth so one client cannot exhaust the service. More about Denial of service.
Is CVE-2026-83614 being exploited?
There is no known exploitation of CVE-2026-83614 in the wild and no public exploit code.
Sources
Also known as AZL-99357, CLEANSTART-2026-NM00684, CLSA-2026-1790458300, DEBIAN-CVE-2026-83614, ECHO-0a23-0681-ea7b, GHSA-93r5-fhx6-vmg9 and 6 more.