# CVE-2026-83614: xmldom: Quadratic-time parsing via the malformed-input recovery path — `parseElementStartPart` re-scan and `normalize()` adjacent-text merge

> Attackers can cause denial of service in applications using xmldom by submitting malformed XML that triggers quadratic-time parsing and normalization loops.

- **Severity:** High 8.7 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:N/VA:H/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 1 Sep 2026
- **Updated:** 1 Sep 2026
- **Also known as:** AZL-99357, CLEANSTART-2026-NM00684, CLSA-2026-1790458300, DEBIAN-CVE-2026-83614, ECHO-0a23-0681-ea7b, GHSA-93r5-fhx6-vmg9, MINI-64jr-pfpg-6847, MINI-hhhq-fjph-v94w, MINI-hj4c-j668-x3vv, MINI-w9g5-xjh6-6pq9, ROOT-APP-NPM-CVE-2026-83614, UBUNTU-CVE-2026-83614

## What is CVE-2026-83614?

CVE-2026-83614 is a high-severity denial of service vulnerability in @xmldom xmldom, published on 1 Sep 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

xmldom is a pure JavaScript W3C standard-based (XML DOM Level 2 Core) DOMParser and XMLSerializer module. Prior to @xmldom/xmldom versions 0.8.15 and 0.9.12, and in xmldom versions 0.3.0 through 0.6.0, two independent quadratic paths can cause denial of service. In lib/sax.js, parseElementStartPart repeatedly rescans a malformed tag name to the next > during single-character recovery; in lib/dom.js, normalize() repeatedly removes and appends adjacent text nodes, causing quadratic reindexing and string rebuilding. The first path is reachable through default DOMParser.parseFromString() processing, while the second is also reachable through a direct normalize() call on a programmatically constructed DOM, and endDocument invokes that normalization after parsing. This issue is fixed in @xmldom/xmldom versions 0.8.15 and 0.9.12; no fixed version is available for xmldom.

Weakness: CWE-407 (Inefficient Algorithmic Complexity), CWE-400 (Uncontrolled Resource Consumption)

## Which versions are affected by CVE-2026-83614?

6 open source packages ship an affected version, including @xmldom/xmldom and xmldom.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `@xmldom/xmldom` | npm | From 0.7.0 | 0.8.15 |
| `@xmldom/xmldom` | npm | From 0.7.0 | 0.8.15 |
| `@xmldom/xmldom` | npm | From 0.9.0 | 0.9.12 |
| `@xmldom/xmldom` | npm | From 0.9.0 | 0.9.12 |
| `xmldom` | npm | From 0.3.0 to 0.6.0 | None |
| `xmldom` | npm | From 0.3.0 to 0.6.0 | None |

## How do I fix CVE-2026-83614?

Upgrade @xmldom/xmldom to a fixed version for your release line: 0.8.15 or 0.9.12.

## Is CVE-2026-83614 being exploited?

There is no known exploitation of CVE-2026-83614 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-83614 and fix it if it is affected.

What it is: CVE-2026-83614 is a high-severity denial of service vulnerability in @xmldom xmldom, published on 1 Sep 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-83614 in the wild and no public exploit code.

Affected packages and fixed versions:
- @xmldom/xmldom (npm): affected from 0.7.0; fixed in 0.8.15
- @xmldom/xmldom (npm): affected from 0.7.0; fixed in 0.8.15
- @xmldom/xmldom (npm): affected from 0.9.0; fixed in 0.9.12
- @xmldom/xmldom (npm): affected from 0.9.0; fixed in 0.9.12
- xmldom (npm): affected from 0.3.0 up to 0.6.0; no fix listed
- xmldom (npm): affected from 0.3.0 up to 0.6.0; no fix listed

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-83614/ (Markdown: https://insights.sbomify.com/CVE-2026-83614/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-83614
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-83614
- OSV: https://osv.dev/vulnerability/CVE-2026-83614

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-83614/
Summaries are generated and may contain mistakes; the official description above is the record.
