CVE-2026-83618 xmldom: requireWellFormed DocType publicId/systemId validation is bypassable via an embedded line terminator

High 8.7 Published Updated

Attackers can bypass XML serialization validation to inject malicious markup, potentially leading to code execution in applications using xmldom.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2026-83618?

CVE-2026-83618 is a high-severity code injection vulnerability in @xmldom xmldom, published on 1 Sep 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

Official description

xmldom is a pure JavaScript W3C standard-based (XML DOM Level 2 Core) DOMParser and XMLSerializer module. From 0.9.10 until 0.9.12, the requireWellFormed: true serializer validates DocumentType.publicId and DocumentType.systemId with PubidLiteral_match and SystemLiteral_match expressions produced by reg() in lib/grammar.js, which inherit the multiline flag. A complete valid literal on the first line can therefore satisfy the matcher while U+000A, U+000D, U+2028, or U+2029 and breakout markup remain in the emitted <!DOCTYPE ...> declaration. This bypasses the strict-serialization mitigation for the earlier DocumentType injection advisory; creation and direct property assignment remain unvalidated by design. This issue is fixed in @xmldom/xmldom version 0.9.12.

Weakness: CWE-91, CWE-625

Which versions are affected by CVE-2026-83618?

2 open source packages ship an affected version, including @xmldom/xmldom.

PackageAffectedFixed in
@xmldom/xmldom npmFrom 0.9.100.9.12
@xmldom/xmldom npmFrom 0.9.100.9.12

How do I fix CVE-2026-83618?

Upgrade @xmldom/xmldom to 0.9.12 or later.

Upgrade, and never evaluate templates, expressions or code built from user input. More about Code injection.

Is CVE-2026-83618 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-83618 exists.

Sources

Also known as DEBIAN-CVE-2026-83618, GHSA-vr34-hp96-76pp, ROOT-APP-NPM-CVE-2026-83618, UBUNTU-CVE-2026-83618.

Is CVE-2026-83618 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free