{"answers":{"affected":"","exploited":"There is no known exploitation of CVE-2026-8368 in the wild and no public exploit code.","fix":"Upgrade to a fixed version.","what":"CVE-2026-8368 is a medium-severity vulnerability in OALDERS LWP::UserAgent, published on 12 May 2026. Any signed-in user can exploit it over the network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2026-8368 and fix it if it is affected.\n\nWhat it is: CVE-2026-8368 is a medium-severity vulnerability in OALDERS LWP::UserAgent, published on 12 May 2026. Any signed-in user can exploit it over the network, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2026-8368 in the wild and no public exploit code.\n\nAffected product: OALDERS LWP::UserAgent. No package-level version data is available, so check the vendor advisory linked from the reference page.\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2026-8368/ (Markdown: https://insights.sbomify.com/CVE-2026-8368/index.md)","id":"CVE-2026-8368","markdown":"https://insights.sbomify.com/CVE-2026-8368/index.md","name":"CVE-2026-8368","record":{"aliases":["AZL-86907","BELL-CVE-2026-8368","DEBIAN-CVE-2026-8368","ECHO-353c-16d7-9c47","GHSA-39wp-j2gg-h44j","MGASA-2026-0150","OESA-2026-2464","SUSE-SU-2026:22353-1","SUSE-SU-2026:2962-1","SUSE-SU-2026:3033-1","UBUNTU-CVE-2026-8368","USN-8378-1","openSUSE-SU-2026:10781-1","openSUSE-SU-2026:21045-1"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["data_read"],"network_reachable":"yes","non_default_config":false,"product_category":"Perl HTTP client library","requires_auth":"low_privilege","summary":"Attackers can steal credentials by triggering cross-origin redirects that leak Authorization headers to malicious hosts.","user_interaction":"not_required","vuln_class":"information_disclosure"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"CPANSec","cpe":[],"cvss":{"score":6.5,"severity":"medium","source":"cisa-adp","vector":"CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:N/A:N","version":"3.1"},"cwes":[{"id":"CWE-522","name":"Insufficiently Protected Credentials"}],"description":"LWP::UserAgent versions before 6.83 for Perl leak Authorization and Proxy-Authorization headers on cross-origin redirects.\n\nOn a 3xx response, the redirect handler strips only Host and Cookie before issuing the follow-up request. Caller-supplied Authorization and Proxy-Authorization headers are sent unchanged to the redirect target, including across scheme, host, or port changes.\n\nA redirect to an attacker controlled host therefore discloses the caller's credentials to that host.","ecosystems":["SUSE:Linux Enterprise Module for Basesystem 15 SP7","SUSE:Linux Enterprise Server 16.0","SUSE:Linux Enterprise Server LTSS Extended Security 12 SP5","SUSE:Linux Enterprise Server for SAP applications 16.0","openSUSE:Leap 16.0","openSUSE:Tumbleweed"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Information disclosure in LWP::UserAgent","id":"CVE-2026-8368","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":null,"product":null,"products":[],"type":"information_disclosure","year":"2026"},"n_packages":6,"n_references":4,"next":{"headline":"Improper Input Validation in OpenThread NAT64 Translator","id":"CVE-2026-8369"},"packages":[{"ecosystem":"SUSE:Linux Enterprise Module for Basesystem 15 SP7","fixed":["6.31-150000.3.3.1"],"introduced":["0"],"last_affected":[],"package":"perl-libwww-perl","purl":"pkg:rpm/suse/perl-libwww-perl\u0026distro=SUSE%20Linux%20Enterprise%20Module%20for%20Basesystem%2015%20SP7","source":"SUSE-SU-2026:2962-1"},{"ecosystem":"SUSE:Linux Enterprise Server 16.0","fixed":["6.770.0-160000.3.1"],"introduced":["0"],"last_affected":[],"package":"perl-libwww-perl","purl":"pkg:rpm/suse/perl-libwww-perl\u0026distro=SUSE%20Linux%20Enterprise%20Server%2016.0","source":"SUSE-SU-2026:22353-1"},{"ecosystem":"SUSE:Linux Enterprise Server LTSS Extended Security 12 SP5","fixed":["6.05-6.3.1"],"introduced":["0"],"last_affected":[],"package":"perl-libwww-perl","purl":"pkg:rpm/suse/perl-libwww-perl\u0026distro=SUSE%20Linux%20Enterprise%20Server%20LTSS%20Extended%20Security%2012%20SP5","source":"SUSE-SU-2026:3033-1"},{"ecosystem":"SUSE:Linux Enterprise Server for SAP applications 16.0","fixed":["6.770.0-160000.3.1"],"introduced":["0"],"last_affected":[],"package":"perl-libwww-perl","purl":"pkg:rpm/suse/perl-libwww-perl\u0026distro=SUSE%20Linux%20Enterprise%20Server%20for%20SAP%20applications%2016.0","source":"SUSE-SU-2026:22353-1"},{"ecosystem":"openSUSE:Leap 16.0","fixed":["6.770.0-160000.3.1"],"introduced":["0"],"last_affected":[],"package":"perl-libwww-perl","purl":"pkg:rpm/opensuse/perl-libwww-perl\u0026distro=openSUSE%20Leap%2016.0","source":"openSUSE-SU-2026:21045-1"},{"ecosystem":"openSUSE:Tumbleweed","fixed":["6.830.0-1.1"],"introduced":["0"],"last_affected":[],"package":"perl-libwww-perl","purl":"pkg:rpm/opensuse/perl-libwww-perl\u0026distro=openSUSE%20Tumbleweed","source":"openSUSE-SU-2026:10781-1"}],"prev":{"headline":"aria2c Improper Certificate Validation","id":"CVE-2026-8367"},"products":["LWP::UserAgent"],"published":"2026-05-12","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"SUSE","prefix":"SUSE"},{"class":"attribution","licence":"CC BY 4.0","name":"SUSE","prefix":"openSUSE"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2026-05-19","vendors":["OALDERS"]},"summary":"Attackers can steal credentials by triggering cross-origin redirects that leak Authorization headers to malicious hosts.","url":"https://insights.sbomify.com/CVE-2026-8368/"}