CVE-2026-83801 Nautobot: Stored cross-site scripting (XSS) in object create/edit form help text
Authenticated users can inject malicious scripts into relationship or module family fields, leading to code execution and privilege escalation in victim sessions.
- Exploited in the wild
- Not known
- Login needed
- Any signed-in user
- Attackable
- Over the internet
- Victim action needed
- A user has to click or open something
- Fix
- Available
What is CVE-2026-83801?
CVE-2026-83801 is a medium-severity cross-site scripting vulnerability in nautobot, published on 22 Sep 2026. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.
Official description
Nautobot is a Network Source of Truth and Network Automation Platform. Prior to 2.4.37 and 3.1.8, a user with extras.add_relationship or extras.change_relationship permission can store HTML or JavaScript in a Relationship description, and a user with dcim.add_modulefamily or dcim.change_modulefamily permission can store it in a Module Family name. Nautobot assigns these values to form field help_text rendered by render_field.html through Django's |safe filter without adequate neutralization. The stored content executes in the authenticated browser session of any user, including an administrator or superuser, who opens an affected create or edit form. This can enable actions as the victim, session or token theft, and further privilege escalation. This issue is fixed in versions 2.4.37 and 3.1.8.
Weakness: CWE-79
Which versions are affected by CVE-2026-83801?
5 open source packages ship an affected version, including nautobot.
| Package | Affected | Fixed in |
|---|---|---|
nautobot PyPI | All versions | 2.4.37, 3.1.8 |
nautobot PyPI | All versions | 2.4.37 |
nautobot PyPI | All versions | 2.4.37 |
nautobot PyPI | From 3.0.0 | 3.1.8 |
nautobot PyPI | From 3.0.0 | 3.1.8 |
How do I fix CVE-2026-83801?
Upgrade nautobot to a fixed version for your release line: 2.4.37 or 3.1.8.
Escape output for the context it lands in and set a strict Content Security Policy. Upgrading the affected component is the real fix. More about Cross-site scripting.
Is CVE-2026-83801 being exploited?
There is no known exploitation of CVE-2026-83801 in the wild and no public exploit code.
Sources
Also known as GHSA-56v6-2fhr-wxgq, PYSEC-2026-4110.