# CVE-2026-8417: Concrete CMS 9.5.0 and below is vulnerable to CSRF in do_update() in the package update controller

> An attacker can force an authenticated administrator to trigger a package upgrade via a cross-site request, potentially leading to privilege escalation or data modification.

- **Severity:** High 7.5 (`CVSS:4.0/AV:N/AC:H/AT:P/PR:N/UI:A/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 21 May 2026
- **Updated:** 22 May 2026
- **Also known as:** GHSA-jr5g-qv3g-rxxx

## What is CVE-2026-8417?

CVE-2026-8417 is a high-severity vulnerability in Concretecms Concrete Cms, published on 21 May 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

Concrete CMS 9.5.0 and below does not validate a CSRF token before processing requests to /dashboard/extend/update/do_update/<pkgHandle>. The do_update() method in concrete/controllers/single_page/dashboard/extend/update.php checks only canInstallPackages() before executing upgradeCoreData() and upgrade() on the named package's controller. Because the endpoint is a state-changing GET route with no token enforcement, an attacker can force an authenticated administrator to trigger a package upgrade via a single cross-site navigation.In order to be vulnerable, the victim must be passing canInstallPackages() and and a target package must already be already installed. The Concrete CMS security team gave this vulnerability a CVSS v.4.0 score of 7.5 with vector CVSS:4.0/AV:N/AC:H/AT:P/PR:N/UI:A/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N. Thanks  https://github.com/maru1009  for reporting.

Weakness: CWE-352 (Cross-Site Request Forgery)

## Which versions are affected by CVE-2026-8417?

2 open source packages ship an affected version, including concrete5/concrete5. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `concrete5/concrete5` | Packagist | All versions | 9.5.1 |
| `concrete5/concrete5` | Packagist | All versions | 9.5.1 |

Products: Concretecms Concrete Cms.

## How do I fix CVE-2026-8417?

Upgrade concrete5/concrete5 to 9.5.1 or later.

## Is CVE-2026-8417 being exploited?

There is no known exploitation of CVE-2026-8417 in the wild and no public exploit code.

## Other vulnerabilities in Concretecms Concrete Cms

- [CVE-2023-48648](https://insights.sbomify.com/CVE-2023-48648/): Concrete CMS allows unauthorized access because directories can be created with insecure permissions (critical 9.8)
- [CVE-2022-21829](https://insights.sbomify.com/CVE-2022-21829/): Code injection in concrete CMS (critical 9.8)
- [CVE-2021-22958](https://insights.sbomify.com/CVE-2021-22958/): Server-Side Request Forgery vulnerability in concrete5 (critical 9.8)
- [CVE-2021-40098](https://insights.sbomify.com/CVE-2021-40098/): Path traversal in n/a (critical 9.8)
- [CVE-2026-8134](https://insights.sbomify.com/CVE-2026-8134/): Concrete CMS Vulnerable to Relative Path Traversal (critical 9.4)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-8417 and fix it if it is affected.

What it is: CVE-2026-8417 is a high-severity vulnerability in Concretecms Concrete Cms, published on 21 May 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2026-8417 in the wild and no public exploit code.

Affected packages and fixed versions:
- concrete5/concrete5 (Packagist): affected all versions; fixed in 9.5.1
- concrete5/concrete5 (Packagist): affected all versions; fixed in 9.5.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-8417/ (Markdown: https://insights.sbomify.com/CVE-2026-8417/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-8417
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-8417
- OSV: https://osv.dev/vulnerability/CVE-2026-8417

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-8417/
Summaries are generated and may contain mistakes; the official description above is the record.
