# CVE-2026-84178: Apache Camel: Camel-OAuth Login Cross-Site Request Forgery via Missing State Binding in the Authorization Code Flow

> Attackers can force victims to log in as attacker-controlled identities via missing state validation in the OAuth flow, leading to account takeover.

- **Severity:** Medium 6.1 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** No
- **Published:** 19 Oct 2026
- **Updated:** 19 Oct 2026
- **Also known as:** GHSA-v54j-mph4-jrf2

## What is CVE-2026-84178?

CVE-2026-84178 is a medium-severity vulnerability in Apache Camel, published on 19 Oct 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

Cross-Site Request Forgery (CSRF) vulnerability in Apache Camel OAuth component.

This issue affects Apache Camel: from 4.11.0 before 4.18.5, from 4.19.0 before 4.22.1.

The authorization code callback did not carry a state parameter binding it to the authorization request that started the flow, and the callback did not verify one. An authorization code obtained in any browser could therefore be redeemed at the callback and associated with whichever session presented it, which is login cross-site request forgery: a victim can be silently signed in as an identity the attacker controls, so that actions the victim then performs, and data they then submit, land in the attacker's account. The same unvalidated callback handling also allowed the post-authentication redirect target to be influenced, giving an open redirect from a trusted origin. The state check runs before the authorization code is redeemed, so these paths are reachable without any interaction with the identity provider.

Upgrade to Apache Camel 4.23.0, which fixes the issue. Users on the 4.18.x LTS releases stream should upgrade to 4.18.5. Users on the 4.22.x LTS releases stream should upgrade to 4.22.1. The authorization request now issues a state value bound to the session, and the callback rejects a request whose state is absent or does not match, stopping the route with a 400 response. For deployments that cannot upgrade immediately, terminate the authorization code flow in a component that performs its own state binding rather than relying on the Camel callback. Note that after upgrading, a deployment behind a proxy that drops or rewrites the callback query string will begin to see 400 responses, because the state parameter must survive the round trip.

Weakness: CWE-352 (Cross-Site Request Forgery)

## Which versions are affected by CVE-2026-84178?


## How do I fix CVE-2026-84178?

No fix has been published for CVE-2026-84178 yet. Limit exposure of the affected software until one is available.

## Is CVE-2026-84178 being exploited?

There is no known exploitation of CVE-2026-84178 in the wild and no public exploit code.

Public exploit code:

- Reproducer for CVE-2026-84178 (Apache Camel camel-oauth): the authorization-code callback redeems the code without verifying a state parameter (login CSRF) — Camel Spring Boot + Camel Quarkus (github_poc): https://github.com/oscerd/CVE-2026-84178

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-84178 and fix it if it is affected.

What it is: CVE-2026-84178 is a medium-severity vulnerability in Apache Camel, published on 19 Oct 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2026-84178 in the wild and no public exploit code.

Affected product: Apache Camel. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-84178/ (Markdown: https://insights.sbomify.com/CVE-2026-84178/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-84178
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-84178
- OSV: https://osv.dev/vulnerability/CVE-2026-84178

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-84178/
Summaries are generated and may contain mistakes; the official description above is the record.
