CVE-2026-84188 librenms before 26.7.0 Stored XSS via graph_descr settings

Medium 4.8 Published Updated

An administrator can inject malicious scripts into graph descriptions, leading to code execution in the browsers of other authenticated users.

Exploited in the wild
Not known
Login needed
An administrator
Attackable
Over the internet
Victim action needed
A user has to click or open something
Fix
None listed

What is CVE-2026-84188?

CVE-2026-84188 is a medium-severity cross-site scripting vulnerability in librenms, published on 1 Sep 2026. An attacker needs administrator access to exploit it, and only if a user opens a file or follows a link.

Official description

LibreNMS versions <= 26.4.0 contain a stored cross-site scripting vulnerability in the graph_descr.<graphtype> configuration settings, which are echoed verbatim without HTML escaping in includes/html/pages/graphs.inc.php. An administrator can store a malicious HTML payload that executes in the browser of any authenticated user who views the affected graph type. The issue is fixed in version 26.7.0.

Weakness: CWE-79

Which versions are affected by CVE-2026-84188?

2 open source packages ship an affected version, including librenms/librenms.

PackageAffectedFixed in
librenms/librenms PackagistAll versions26.7.0
librenms/librenms PackagistAll versions26.7.0

How do I fix CVE-2026-84188?

Upgrade librenms/librenms to 26.7.0 or later.

Escape output for the context it lands in and set a strict Content Security Policy. Upgrading the affected component is the real fix. More about Cross-site scripting.

Is CVE-2026-84188 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-84188 exists.

Sources

Also known as GHSA-7cj5-v4pp-v632, GHSA-pvwj-jwv3-68ww.

Is CVE-2026-84188 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free