# CVE-2026-84188: librenms before 26.7.0 Stored XSS via graph_descr settings

> An administrator can inject malicious scripts into graph descriptions, leading to code execution in the browsers of other authenticated users.

- **Severity:** Medium 4.8 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:H/UI:P/VC:L/VI:L/VA:N/SC:L/SI:L/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** An administrator
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** No
- **Published:** 1 Sep 2026
- **Updated:** 8 Oct 2026
- **Also known as:** GHSA-7cj5-v4pp-v632, GHSA-pvwj-jwv3-68ww

## What is CVE-2026-84188?

CVE-2026-84188 is a medium-severity cross-site scripting vulnerability in librenms, published on 1 Sep 2026. An attacker needs administrator access to exploit it, and only if a user opens a file or follows a link.

### Official description

LibreNMS versions <= 26.4.0 contain a stored cross-site scripting vulnerability in the graph_descr.<graphtype> configuration settings, which are echoed verbatim without HTML escaping in includes/html/pages/graphs.inc.php. An administrator can store a malicious HTML payload that executes in the browser of any authenticated user who views the affected graph type. The issue is fixed in version 26.7.0.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2026-84188?

2 open source packages ship an affected version, including librenms/librenms.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `librenms/librenms` | Packagist | All versions | 26.7.0 |
| `librenms/librenms` | Packagist | All versions | 26.7.0 |

## How do I fix CVE-2026-84188?

Upgrade librenms/librenms to 26.7.0 or later.

## Is CVE-2026-84188 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-84188 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-84188 and fix it if it is affected.

What it is: CVE-2026-84188 is a medium-severity cross-site scripting vulnerability in librenms, published on 1 Sep 2026. An attacker needs administrator access to exploit it, and only if a user opens a file or follows a link.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-84188 exists.

Affected packages and fixed versions:
- librenms/librenms (Packagist): affected all versions; fixed in 26.7.0
- librenms/librenms (Packagist): affected all versions; fixed in 26.7.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-84188/ (Markdown: https://insights.sbomify.com/CVE-2026-84188/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-84188
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-84188
- OSV: https://osv.dev/vulnerability/CVE-2026-84188

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-84188/
Summaries are generated and may contain mistakes; the official description above is the record.
